Starting anbox container



  • Hi Everyone,

    I wanted to share my experience with getting the anbox container to start after installation as well as ask a question. I have read on here that some people are having difficulty getting the container started after they have installed anbox from the instructions. Here is what worked for me:

    SYSTEM
    OS: 16.04
    Device: Oneplus One (bacon)

    • Reboot the device after installation

    • Note: I used a bluetooth keyboard for my device after this point, but you may be able to do something similar using adb shell with the device connected to a PC.

    • On the device (the ubuntu-touch device), open the terminal

    • Likely, adb devices will show the device to be offline.

    • Do anbox-tool upgrade

    • Once it finishes, check that the container has be started by doing adb devices. The emulated should now have a status of device, I believe (or at least it is not offline anymore).

    This seems to work for me and I am able to install android apps pulled from my android device (although they don't appear to work... but that is another post).

    My question is, is there a better way to get the container running after reboot? It seems to me that anbox-tool upgrade is like using a machine gun to kill a fly. Is there a file in the ubuntu touch filesystem that can be edited to run anbox-tool upgrade or whatever the line is in anbox-tool upgrade that starts the container?

    As another experiment, I tried the following:

    • reboot device
    • open terminal
    • run sudo mount -o rw,remount /
    • adb devices still shows the container to be offline.
    • anbox-tool upgrade does the trick to start the container.


  • @aclifton314 anbox-tool enable



  • @mihael Thank you for your response. Here is what I did:

    • Reboot device.
    • Launch terminal.
    • adb devices shows container to be offline.
    • anbox-tool enable shows Anbox is already enabled
    • adb devices shows container to be offline.
    • sudo mount -o rw,remount /
    • anbox-tool enable shows Anbox is already enabled
    • adb devices shows container to be offline.
    • anbox-tool upgrade, then adb devices shows container to be started.


  • @aclifton314 You can try to play with anbox-tool disable and then anbox-tool enable...



  • @mihael ah yes. The toggling does work for me. Thanks!


Log in to reply