Fairphone 2 (FP2)



  • @Fla When you flashed your phone with the Halium 7.1 version, you took the images I provided to you and you also needed to download the current rootfs (dev) build from the CI-Server.
    So you just can download the new rootfs build and flash your phone again with that command:

    path/to/halium-install -p ut path/to/rootfs.tar.gz path/to/system.img
    
    

    (Perhaps there is a way to flash the rootfs only? Hm, perhaps it is possible to flash the phone with the ubports-installer without flashing the boot-partition and the system-image, I don't know.)

    After doing that, you need to make changes, which you did to the rootfs, again. For Example the droid-cam patch.



  • I just created a new build of the halium and the system images:
    https://drive.google.com/open?id=19xoNR-h-G1m8RUpJjA_6VTLWXvH40FH-

    I am not sure, if there are changes in halium, but @peat_psuwit did add the minimum brightness fix to the FP2 device config. Therefor this should work out of the box now.

    For installing follow this instructions:
    https://docs.ubports.com/en/latest/porting/installing-16-04.html#install-halium-boot
    From "Install halium-boot" until "Install system.img and rootfs". That should do it.

    For the camera to work fast and with flash, follow this instructions.
    Or just "wget" this script on your phone's terminal and execute it.
    Don't forget to install the patched camera app.



  • @Luksus thank you, I will install it and report if I have new problems.



  • @Fla
    I've been now for 1.5 weeks on UT with OTA-12 (stable channel) again. I use the Halium 5.1 based Image from ubports installer and after reading a bit in the Halium 7.1 thread (complicated Installation, Risk to burn the LED, …) I will stick to it and not try the Halium 7.1 Image now.

    Indeed, UT is much more stable than a year ago. I've had two "hard" reboots now, one when I tried to take a photo (I remember this to trigger reboot from a year ago, seems to be an Halium issue …) and one I think when I was Messing around with Anbox. Lomiri crashes I've had like three while using it (one with Anbox, one when many apps were open, one just random), but that is also better. A year ago it was like 3 Lomiri crashes within one hour on the FP2.

    I've tried Anbox as it is easy to install now (basically just apt install anbox-ubuntu-touch). The experience is not soo good, I described it here: https://forums.ubports.com/topic/1676/development-testers-for-anbox/215

    I want to thank here to all UT developers. 🙂 It's a big Progress again in the OS. I already found nice new small Features like finally an integrated timer in the Clock app etc. And hopefully, with Pinephone etc. coming up, there will also be more General interest in UT and more People will take over the development of UT apps or develop new apps (I was glad to see that now in Openstore there are also some SailfishOS ported apps).



  • @rom4nb hey man, you've got to know: yesterday i was going to answer saying i agreed: the fp2 is heaps more stable, good job to everyone... and then lomiri crashed on me in the middle of my message, while I was doing nothing else ^^ It's hard to convey how hilarious it was at the moment



  • @Luksus thanks, I did the update and everything worked well. In your script to install gst-droid, you should remove the holding of qtubuntu, this package isn't there anymore (see original topic: UPDATED: qtubuntu packages have been removed from the repository, thus no pinning is required anymore).



  • @Luksus well no, everything isn't working fine: I can't do phone calls. I call someone, we can discuss and then after less than a minute, I can't hear the other participant anymore. At that time, the button to hang isn't working.

    @peat_psuwit did you change anything in the halium part since a few months back?



  • @Fla The only change recently is the addition of repowerd config file.



  • @Fla for me it works with the rootfs from 12 days ago. So I assume it could be caused by the rootfs build you have used.



  • The phone call feature itself isn't the problem, the problem is the lost of the network. But after a few days (maybe thanks to a reboot?) I don't have it anymore. It looks like network signal isn't really good, no idea if it's related to that new port, to the phone hardware itself, to UT in general, or because of the carrier... But the problem is mainly gone anyway.



  • @peat_psuwit I would really love to be able to have OTA update on my FP2 running that port. Is there anything I can do to help you make it official?



  • Since Fairphone managed to run Android 9 on the FP2, would it be possible to create a Halium 9 Port with this GSI thing?
    https://www.fairphone.com/en/2020/06/18/fairphone-2-gets-android-9/



  • @Luksus said in Fairphone 2 (FP2):

    Since Fairphone managed to run Android 9 on the FP2, would it be possible to create a Halium 9 Port with this GSI thing?
    https://www.fairphone.com/en/2020/06/18/fairphone-2-gets-android-9/

    I've asked the same question on fairphone forum. The answer is:

    No, because of
    Halium version 9 is basically for phones released with android 8 or later, in other words devices with vendor partition.
    The FP2 does not have a vendor partition.


Log in to reply