howto install linux-headers



  • Hi,
    I need install linux-headers but it isn't found.
    The kernel version is "3.10.93+".
    When I try to install with:
    sudo apt install linux-headers-$(uname -r)
    it returns:
    E: No se ha podido localizar el paquete linux-headers-3.10.93
    E: No se pudo encontrar ningĂșn paquete usando "*" con "linux-headers-3.10.93"
    Thank's
    Do I need to add any repository to apt/sources.lst?
    Do I have to update the kernel?



  • Why do you think you need to install this on the phone? You almost certainly don't.

    Of course such a package is not available, because the kernel is from Android, not Ubuntu.



  • I need it to compile a library that use my program.



  • Each phone has a different kernel, so if whatever you need depends on the kernel headers matching the specific kernel that is running, then it won't work on the phone.

    In Libertine though, you can simply install the linux-headers-generic package to get the normal Ubuntu kernel headers available to compile against, if you really want to compile stuff on a phone.


Log in to reply