Nexus 5 Hotspot has two BSSID numbers?



  • My Nexus 5 has the latest updates. When I use hotspot, two BSSID vendor names and different numbers appear on my WIFI sniffer app on OSX. One station is Google, Inc. and the other LG Electronics. It seems the LG Electronics works all the time and Google, Inc. gives me problems when trying to connect to the Nexus 5 hotspot. I have to try up to three times with the hotspot switch in the main settings menu. I see the connect attempt with Google, Inc. a few minutes in the past as logged by the wifi sniffer, if I understand it correctly. I don't have any choice in connectivity between the two stations - it's like roulette - I get connectivity after three attempts at most and LG Electronics is the one working. Can anyone give me pointers on why two BSSID vendors keep popping up?



  • @air409 Edit: According to the wifi sniffer, there are two vendor names, two BSSID station addresses (different), channel widths, security, etc. appearing under the same name I gave my hotspot.



  • @air409 Update: Today when I started the Nexus 5 hotspot, the station was acquired and logged into immediately with no problem. The station vendor name on the wifi sniffer was LG Electronics which is always the vendor it has no problem with. The vendor name Google, Inc. did not show up at all today. I still don't know why and will keep watch on it.



  • Today after several tries I was able to get the hotspot working on my Nexus 5. I tried different menu click combinations on the Nexus and none of the usual combinations worked. I'm using it now as I type this. The wifi sniffer said that the vendor name is Google, Inc. now on this connection I have today. Google, Inc. and LG Electronics kept popping up at the same time a few times as vender name and mostly LG Electronics, but I was not able to get a connection on either. Google, Inc. went through three different BSSID addresses before I had internet. This is the first time I've seen it connect to the Google, Inc. address. It seems like there is a fight going on between LG and Google. On my Mac, the network connection window shows the hotspot name twice and the check mark alternates between the two like it cannot make up it's mind which one to connect to. Maybe in a future UT update this problem can be worked out. If anyone has an idea on what I can do to help my computer connect to the hotspot, then please let me know. If you are using Linux or BSD then that would be helpful to know, too. My Mac is on the Catalina OS update. Thanks.


Log in to reply