SOLVED: Clickable create failing

  • Hello,
    I'm wondering whether the following issue is worth reporting or it's just an issue on my end.
    On CentOS 7 clickable create ends with the following exception:

    Traceback (most recent call last):
      File "/home/h134607/.local/lib/python3.6/site-packages/clickable/", line 253, in main, args)
      File "/home/h134607/.local/lib/python3.6/site-packages/clickable/", line 237, in run
      File "/home/h134607/.local/lib/python3.6/site-packages/clickable/commands/", line 52, in run
      File "/home/h134607/.local/lib/python3.6/site-packages/cookiecutter/", line 63, in cookiecutter
      File "/home/h134607/.local/lib/python3.6/site-packages/cookiecutter/", line 103, in determine_repo_dir
      File "/home/h134607/.local/lib/python3.6/site-packages/cookiecutter/", line 99, in clone
      File "/usr/lib64/python3.6/", line 356, in check_output
      File "/usr/lib64/python3.6/", line 438, in run
        output=stdout, stderr=stderr)
    subprocess.CalledProcessError: Command '['git', 'clone', '']' returned non-zero exit status 128.

    After I appended the .git suffix to the value of COOKIECUTTER_URL in file ~/.local/lib/python3.6/site-packages/clickable/commands/ it started working.

  • Sounds like a bug to me. If you file an issue and create a pull request with your change, I am sure the maintainers and all developers on your version of CentOS would be highly appreciative.

  • Thanks,
    It turned out that it is a Git related issue (older versions require the .git suffix).
    I created the issue:
    How do I move on with the fix? I can't create a branch on the server and I can't push my local branch to the server either? Do I need to wait for the repo owner to approve the issue first?

  • Assuming you have a gitlab account (and I think you do, since you opened the issue), you could:

    • fork the repo to your account,
    • clone that to your local machine,
    • apply your fix on your local copy,
    • commit and push to your copy of the repo,
    • open a merge request (MR) from your repo to the original one,

    Then you have to wait for your MR to be accepted. Usually Brian is quite quick on the uptake.

  • In the meantime Brian fixed it and closed the issue 🙂
    Thanks anyway, I didn't know that merge request between repos is a thing.

Log in to reply