SIM not detected on Nexus 5



  • I installed Ubuntu Touch on a Nexus 5. Everything I tested is working fine. Internet connection by WiFi is OK. The problem is that the SIM card is not detected. Googling a lot came to a possible answer :
    https://forum.xda-developers.com/ubuntu-touch/help/sim-detected-nexus-5-t2858419
    Which says :
    Solved thanks to a script in /usr/share/ofono/scripts/ which is "enter-pin"
    So, try typing in a terminal ("xxxx" is your pin code):

    /usr/share/ofono/scripts/enter-pin pin xxxx

    I tried it but got an error :

    phablet@ubuntu-phablet:~$ /usr/share/ofono/scripts/enter-pin pin 0000
    Enter Pin for modem /ril_0...
    Traceback (most recent call last):
      File "/usr/share/ofono/scripts/enter-pin", line 27, in <module>
        simmanager.EnterPin(pin_type, pin)
      File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 70, in __call__
        return self._proxy_method(*args, **keywords)
      File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 145, in __call__
        **keywords)
      File "/usr/lib/python3/dist-packages/dbus/connection.py", line 651, in call_blocking
        message, timeout)
    dbus.exceptions.DBusException: org.ofono.Error.InvalidFormat: Argument format is not recognized
    

    I don't know what is the format error.
    Otherwise, where can I enter the SIM pin code ?
    I am locked there.
    It could also be a hardware problem, I tried to reinsert the card several times, but no change.
    Thanks for any idea.


Log in to reply