USB Serial in libertine container



  • Hi there,

    new user here, I've just installed ubtouch on my Nexus 7 and I try to setup a development box with PlatformIO.

    For that I require usb serial ports, which register as /dev/usbdev1.1

    What is the best way to get access to a serial port from within a container?

    I've tried adding this to /etc/lxc/default.conf (after issuing sudo mount -o remount,rw /):

    lxc.mount.entry = /dev/bus/usb dev/bus/usb  none bind,optional,create=dir 0 0
    
    lxc.cgroup.devices.allow = c 189:* rwm
    lxc.mount.entry = /dev/usbdev1.1 dev/usbdev1.1 none bind,optional,create=file 0 0
    lxc.mount.entry = /dev/usbdev1.2 dev/usbdev1.2 none bind,optional,create=file 0 0
    

    That seems to work, but I need to manually chmod 666 the device files.

    To automate that, I've tried to add a script that chmods...

    sudo echo "/sbin/hotplug" > /proc/sys/kernel/hotplug
    -bash: /proc/sys/kernel/hotplug: Permission denied
    

    but that does not work.

    Probably I'd need a user-serial kernel module, but I presume that would not work with the released kernel?
    Any advise hot to set that up properly?

    Thanks

    pit


Log in to reply