Problem with connect to WPA2-Enterprise AP w/o CA



  • Colleagues, please tell me how to solve my problem!

    I have a WiFi access point, builded on the current version of OpenWRT. She uses hostapd and external FreeRADIUS.
    For a normal connection with her, I need to set the following parameters: security: WPA2-Enterprise, autorisation: PEAP, version PEAP: auto, internal autorisation: MSCHAPv2, no CA, user, password.
    My Mac Mini connects absolutely normal.
    My notebook with Linux Mint too.

    Unfortunately, my tablet and phone with UBPorts (Ubuntu 16.04 LTS 20191016) do not connect.
    Message: Incorrect authentication data.

    Since hostapd does not write anything to the log file at all, I believe that he does not connect to it at all.
    I believe that the client, seeing that the certificate does not have a CA, terminates the connection.

    At the same time, I set in menu, that the CA certificate is missing.
    Perhaps this is a bug in the Wi-Fi section of system setup program.

    Can someone tell me how to fix this problem?

    Ogogon.



  • First, please specify exactly which devices you are using Ubuntu Touch on, and what exact versions of Ubuntu Touch you're on. The latter information is on the About page in System Settings and if you're on stable should say something like OTA-11.



  • I use phone BQ Aquaris E5 Ubuntu Edition and tablet Aquaris M10 FHD Ubuntu Edition.
    Both use Ubuntu 16.04 (OTA-11)



  • Hi!

    I had some wifi problems with NVRAM and a BQ device, see this thread:

    https://forums.ubports.com/topic/3197/any-news-about-m10hd-cooler-wifi-problem/18


Log in to reply