Enable ssh



  • Hi folk!
    I see a previous similar question has been asked but I can’t access it - it says “access denied”.

    I’ve just done a fresh load os this morning and would like to enable ssh. Developer mode is not in the settings>about menu so I can’t make an adb shell to load a cert.

    The docs I’ve read don’t appear to mention how to turn on ssh after it was turn off by default a few releases ago.

    Can you please tell me how to enable ssh? Or point me to the right resource?



  • Edit /etc/ssh/sshd_config to allow access then start the service with

    sudo service ssh start



  • Thanks for this pointer. I got to the same part - I've enabled password authentication but it's still looking for identity files. I'll keep playing and post back when I get it.



  • I got to the point where is asks for a password but won't accept my password. Word of caution: don't change your password from command line if you've enabled passcode - when you phone locks it only gives you a numpad to enter your password, not a keyboard.


Log in to reply