Oneplus One installer hangs on "flashing firmware"

  • Hi guys,

    Longtime user of UBPORTS and donated years ago. Also have a family member using it as their daily driver, also on a Oneplus One.

    My Oneplus One developed an issue so I got a new motherboard installed. Absolute nightmare trying to find someone to do that btw.

    I have now installed the latest baseband/radio/modem firmware as per a post here on the forum. Then I installed the latest Teamwin recovery. Then I installed the latest version of Lineage.

    The problem is that I cannot now get UBports to boot.

    When using the installer, if I tick the box "Bootstrap Flash system partition using fastboot" the installer hangs on the "flashing firmware" stage.

    If I leave that box unticked and install with the "wipe" box ticked the installer works, sends the files to the device, the installer says Ubports successfully installed, the device reboots to recovery. When I reboot the device again it just reboots to Lineage, ubports was never installed.

    I have tried the .deb installer and the appimage installer. I cannot install snaps on this system, it is an old version of mint and I cannot update it currently.

    Fastboot and adb see the device fine, and the device is fastboot unlocked.

    Any help would be much appreciated.

    Great work as always folks and the project really looks like it is going from strength to strength with the pinephone etc.

  • @yeke_yoke said in Oneplus One installer hangs on "flashing firmware":

    Flash system partition using fastboot" the installer hangs on the "flashing firmware" stage.

    I have the same problem. I haven't tried disabling the "fastboot" option yet.
    For the issue you're having, could it be something similar to the "Update Cyanogen Recovery" feature in the developer settings in CyanogenMod? There might be something similar in LineageOS that could cause issues.

  • @ok-what
    Hi, just seeing your post now,

    I installed successfully by using the snap installer and a brand new usb cable (I tried many other old cables), outlined in another thread I posted.

    Hope that helps you install, let me know if you're still having trouble.

Log in to reply