Nexus 5 power button no longer shuts off display



  • Hello,

    I am running the Development channel on a Nexus 5. On 25 or 26 June I ran an update, and on Friday 26 June I noticed some screen problems. I have run updates since then (I am now using 1586), but they have not fixed the issues. The following problems are currently 100% repeatable on my device.

    • Pressing the power button once no longer blanks/shuts off the screen. Pressing and holding the power button does still give a shutdown menu as normal and also can power on the device, so the button is not broken.
    • When the screen blanks due to timing out, it does not actually turn off. If I look at it in a dark room, the screen is gray instead of black, meaning that there is light being generated instead of it actually being off.
    • The display brightness no longer adjusts. When I move the slider on the screen brightness page, it has no effect.

    Is this the right place to post bugs like this, or is there a separate bug reporting system I should be using.



  • I switched to the Stable channel and all of the issues that I mentioned above were resolved and working properly.



  • @JoeBeach yes this is a know bug, the team is working on it or already fixed it. I've also went back to RC 🙂



  • Is it safe to update the dev channel again? I have been holding back on the update due to this warning.



  • @poVoq Hi, the issue is still unsolved (Nexus 5 dev)



  • @JoeBeach @poVoq @lduboeuf I am on edge channel and the power button is working here now👍 👏 😄
    And the back light is turned off when the screen is turned off.



  • @poVoq It is fixed also on the dev channel



  • @Capsia thanks for the notice.

    But I think I found a bug. I previously downloaded dev channel 1583 but never installed it. But now there is no option to discard that previously downloaded version and look for a newer one. So unless I actually install that buggy version I seem to be stuck? (edit: playing around with the channel without actually changing anything seems to have fixed it and now I can download 1592; still odd...)


Log in to reply