"The" Bluetooth Thread



  • I'm trying to pair a meizu pro 5 with the audio system in my vauxhall/opel antara
    The phone recognises the system but doesnt bring up a screen to input the pin code generated, it then fails to connect with the audio unit display saying 'connection failed'



  • I have been using Ubuntu touch now for a little more than a week as my main phone.
    One issue I have been bothered by is the call quality on my end for Bluetooth connections. on my nexus 5 I am able to pair with several devices, such as our 2018 ford explorer, a set of cheap bluetooth headphones, a jabra ear piece and a high end bluetooth headphones set. In every case In, music and podcast sound great. Audio quality is great, volume fine, no strange compression sound that one can hear over Bluetooth running under some protocols. However in every case call quality is so poor its not worth using. The audio is digitized sounding almost as if the caller is using a transformers voice changer toy for Megatron.
    Is this just my nexus 5? is it Ubuntu touch? any ideas???



  • OK...
    So Bluetooth working correctly will make or break it for me to use touch as my OS.
    Two days ago I was pulled over and was given a $206.00 fine for talking on my phone. this is 4x more than the cost of my nexus 5!!!
    I can use earbuds, they work great... But strange thing is I can't plug into my aux in my car, I get a similar result as I do with Bluetooth. I'm starting to think this is a specific problem with the phone I have, not Ubuntu, or a problem with nexus 5 only... Does anyone else have issues with call quality while on Bluetooth in nexus 5??



  • @matridium just have a look at the 7th and 8th post in this thread to find someone else having problems with bluetooth on the nexus 5... The thread as a hole shows, that Ubuntu touch has some fundamental issues with bluetooth (i.e. audio quality on calls). You may check wether the problem is with you phone by flashing android or lineage os... But I doubt it is... Unfortunately... šŸ˜•



  • Yup did that this morning, I flashed back to stock and BT works fine, switch back to UBuntu, and same issue as before... Bummer...:( I hope this is something that can be fixed. My Xperia X compact runs fine on Sailfish X, and bluetooth is great on it. I'm just not that into Sailfish.



  • [xenial] Nexus 5 (r387) bluetooth shows connection to Bose Sound Link II speaker. Speaker does not acknowledge connection, which it does when connected to from Android device. Does Bluetooth work with audio devices (headphones/speakers)? Is this a bug which should be raised in 16.04 Backlog or 16.04 OTA-4/5? Thanks



  • Update from Pro 5 with xenial (r96):
    Bluetooth connection to Volvo Car works and music streaming did work. Once. 2nd time no sound from the car system. Phone connected. Initiating call from phone or car kit works, but there is no sound. After a brief noice, the audio goes quiet. Hanging up, phone book, etc. accessible from the car kit, but no sound. It seems to me this may be an issue with the phone app. I have had similar issues connecting my phone to BT headset or speaker before. Just noice, no audio from the phone call.

    So, bluetooth connection appears to work as expected, but audio routing has issues. I will test it further, but it is encouraging to see my phone connect to the car kit when I get into the car, that hasn't happened since my Bq Aquaris E4.5 with Canonical's image on it.



  • @fourloop My nexus does connect to my Bose mini speaker but it has taken two or three attempts sometimes for it to work correctly even once after the handshake beep. Have just restarted from the speaker end.



  • Hyundai i20 and bq E5 audio works (music or in a call), car buttons Ā«hangupĀ» and Ā«callĀ» works (but I didn't try to access to my contacts).



  • I tried to pair my Nexus 5 with my car's (Subaru Forester) audio system via Bluetooth. The phone detects the audio system but there is no dialog box to enter the PIN from the audio system in the Bluetooth setup. The audio system thus refuses the connection request. Is there any work-around for this ?
    Thanks.



  • My 2 cents worth about bluetooth
    I feel that Bluetooth being in good working order is of utmost importance,once 16.04 is funtioning well.
    My thoughts are that when UBports gets onto Librem 5, and the bluetooth is at this standard, UBports will be dropped like a hot brick,in favor of the alternatives.

    I used to drive a lot, with 2 headsets both bluetooth, one ,(set via bluetooth settings in the phone ) for calls and the other for Music
    The one I used for calls was the type truckers use because the mike would only pick up your voice and no background sounds.
    Just some food for thought, when you guys are thinking about bluetooth.



  • @Marathon2422
    I can't agree more! Bluetooth has been unreliable ever since the launch of Ubuntu Touch. BLE devices never worked well and last time I tested with a BLE keyboard I couldn't bring the OSK back after disconnecting the KB. Car kits, as I stated above, has not worked for me since my Bq E4.5. While it connects fine, there is no audio or mic routed through the phone app. My Pebble Round watch connects, but the BT connection is not recognized by the Rockwork app.

    Many smartphone users today, rely on bluetooth for handsfree phone callls, external speakers, smart watches, mice and keyboards, so I believe it is essential this works flawlessly in Ubuntu Touch too.


  • Banned

    Using 16.04/rc installed yesterday on Nexus 5, no major Bluetooth problems for me. Sometimes takes a couple tries to connect but seems to use high fidelity profile by default and switches output as soon as connected. Music player works really well with my 20+ GB MP3 collection too. Shows album covers from folder.jpg rather than demanding every song have the same image embeded, for example.

    UBports really breathed new life into this old phone. Looking forward to the official release!



  • @crito What about phone calls, do you get any sound through bluetooth?



  • @tomoqv I connected my OPO to the my Fiat 500L Uconnect bluetooth system, all is ok but no audio through the car speakers



  • @rocky58 That is my problem too, Pro5 connects fine with car kit, but no audio.



  • @crito said in "The" Bluetooth Thread:

    Using 16.04/rc installed yesterday on Nexus 5, no major Bluetooth problems for me. Sometimes takes a couple tries to connect but seems to use high fidelity profile by default and switches output as soon as connected. Music player works really well with my 20+ GB MP3 collection too. Shows album covers from folder.jpg rather than demanding every song have the same image embeded, for example.

    Funny - I am running the same, also on a nexus5 - but my Bluetooth can't seem to discover any devices at all... Tried it with my radio yesterday, and it didn't show up on the list. Even if both were on and no other devices were using Bluetoooth.



  • Sigh - my MX4 just died because of rain, so I have to switch to my OPO.
    Nice phone, but Bluetooth doesn't work, and I need that for my car, as I spend a lot of time in my car.
    Any news on progress of Bluetooth or do I have to bite the Linage apple? Any other UBports-compatible phone where Bluetooth works?

    Regards Grisen



  • @grisen Bluetooth works on my OPO 16.04 dev. Some devices it detects quickly, others take two or three attempts.Does it not connect at all or just no audio as others gave reported on different devices.



  • It's stuck at "Searching"
    It never finds my car.

    Regards
    Grisen


Log in to reply