Problem with libertine

  • Hi guys, I have problem when I create one container with this command

    libertine-container-manager create -i myapp

    return this

    libertine-container-manager:123: ERROR: create(): Impossible crete container: 'No module named 'libertine.LxdContainer''

    Why? How resolve?

    Thank you

  • @xinyiman said in Problem with libertine:


    python3-libertine-lxd package is, I believe, required to create LXD containers and it's not installed by default. As for why it's not installed -- I don't know. We need someone more knowledgeable here 🙂

    How resolve?

    libertine-container-manager create -i myapp -t chroot will create a chroot container

  • Thank you, with your suggestion I have created my first container. But now I moved my gtk application into this path:

    cp test_laz2 ~/.cache/libertine-container/myapp/rootfs/tmp/

    But now how do I launch my application inside my container?

  • I haven't tried to run desktop applications from Libertine, so have no experience here.
    For command line apps libertine-container-manager exec and libertine-launch commands works for me.

    Have you tried running ubuntu-app-launch <CONTAINER_ID>_<desktop_file_name>_0.0 command (from the docs)?

Log in to reply