Unity System Compositor crashes (failed to get hwcomposer service)

  • Hi everyone, I've been trying to port Ubuntu Touch to my Xiaomi Redmi K20 Pro (raphael), using Halium 9 with the help of the GSI.

    I'm almost there - but LightDM crashes, because unity-system-compositor crashes.
    Below is the contents of /var/log/lightdm/unity-system-compositor.log:

    [2020-07-21 03:22:44.018348] <information> mirserver: Starting
    [2020-07-21 03:22:44.019006] < - debug - > mirserver: Using Linux VT subsystem for session management
    [2020-07-21 03:22:44.019123] <information> mircommon: Loading modules from: /usr/lib/arm-linux-gnueabihf/mir/server-platform
    [2020-07-21 03:22:44.019168] <information> mircommon: Loading module: /usr/lib/arm-linux-gnueabihf/mir/server-platform/graphics-android-caf.so.15
    [2020-07-21 03:22:44.019180] <information> mircommon: Loading module: /usr/lib/arm-linux-gnueabihf/mir/server-platform/graphics-android.so.15
    [2020-07-21 03:22:44.019188] <information> mircommon: Loading module: /usr/lib/arm-linux-gnueabihf/mir/server-platform/input-evdev.so.7
    [2020-07-21 03:22:44.036631] <information> mirserver: Found graphics driver: mir:android-caf (version 1.8.0) Support priority: 0
    [2020-07-21 03:22:44.036800] <information> mirserver: Found graphics driver: mir:android (version 1.1.0) Support priority: 256
    [2020-07-21 03:22:44.036953] <information> mirserver: Selected driver: mir:android (version 1.1.0)
    [2020-07-21 03:22:44.063923] <information> android/server: Error opening HWC HAL. Assuming HWComposer 2 device with libhwc2_compat_layer.
    failed to get hwcomposer service

    Does anyone know what's happening here?

    My device tree
    My kernel fork

  • @hacker1024 Great you could figure it out.

    Can you mark the thread as solved (Topic Tools -> Ask a question then -> mark as solved) so people could find the answer easily.


Log in to reply