libertine-container-manager create fails:

  • I run via ssh:
    libertine-container-manager create -i prio1 -t chroot
    The first error message:
    I: Configuring libc-bin... W: Failure while configuring required packages. W: See /home/phablet/.cache/libertine-container/prio1/rootfs/debootstrap/debootstrap.log for details (possibly the package makedev is at fault)
    The mentioned file contains the following lines for libc-bin:
    Processing triggers for libc-bin (2.23-0ubuntu3) ... Errors were encountered while processing: makedev (Reading database ... 6882 files and directories currently installed.
    Later on:
    I: Configuring libc-bin... W: Failure while configuring base packages. This will be re-attempted up to five times. W: See /home/phablet/.cache/libertine-container/prio1/rootfs/debootstrap/debootstrap.log for details (possibly the package makedev is at fault)
    Setting up makedev (2.3.1-93ubuntu2~ubuntu16.04.1) ...^M grep: /proc/1/environ: Permission denied^M mknod: mem-: Permission denied^M makedev mem c 1 1 root kmem 0640: failed^M mknod: kmem-: Permission denied^M makedev kmem c 1 2 root kmem 0640: failed^M mknod: null-: Permission denied^M makedev null c 1 3 root root 0666: failed^M mknod: port-: Permission denied^M makedev port c 1 4 root kmem 0640: failed^M mknod: zero-: Permission denied^M makedev zero c 1 5 root root 0666: failed ...

    I reproduced this behavior 4 times.
    Any help for my OnePlus 3T?

  • @sven Hi! Have you used Libertine before? I'm asking because it's known that is buggy, I never tried it.

  • @C0n57an71n I am returning user of Ubuntu Touch. When I first used it in 2017 (?), there was no such nice idea like Libertine. So, today was my first try with Libertine. I think Libertine could offer many benefits, so I hope at least to see some workaround suggestions ...

  • @sven I understand! I think you are the third person who's referring to Libertine int the least couple of hours... I'm telling you what I know: it's still in development so expect bugs. I think the team work hard to make one phone fully functional and then move further with "one OS/All machines" concept, but is just a guess...

  • @sven I saw some errors scroll by when I created a container on my PinePhone too. But I decided to ignore them, since in the end the container was created either way.
    Did the container creation fail for you?

  • @arubislander Yes, it failed in the end, failure was reported and the remains were automatically deleted.

  • Sorry to hear. In that case, I am not certain of the status of Libertine on the OP3T

    Edit: Found this forum post that mentions libertine not working. Admittedly it is an old post, but still...

  • I'm getting the same problem, also with the oneplus 3t device...

    Did someone get a solution?

Log in to reply