Testing the upgrade to Qt 5.12



  • @Isaac If you are using the logviewer app, be sure to set the username to something reasonable, in the settings of the app first.



  • @lduboeuf Very odd. Hopefully the e4.5 arrives here soon and I can reproduce these issues with it.



  • Morph goes down when i try to paste text in adressbar.



  • Same happens when mark page as a bookmark. Restarting the app i see that page bookmarked.



  • @Isaac please provide logs of the crash. You can use the logviewer app to do so.



  • @Fla unity8.log
    Error ocurred uploading to Pastebin (i've changed the name in logviewer settings, still fails)

    Now i can past texts in adressbar, but it still shuts down on bookmarking.



  • On the OP3 it looks like most things work fine.

    I do have some issues though:

    • As others have already stated the calander and clock crash.

    • Teleports doesn't show any of my messages

    • The messaging app doesn't display the coloured bubbles.

    • Lomiri's App drawer looks a bit weird, it usually renders 5 icons that fills the app drawer, now its missing a column, and thus leaves a notable space on the right of lomiri.

    • The Gallery app shows images fine, but when I go to try and edit a image to crop, it turns black and doesnt give me the option to crop.

    • Dekko just shows up as a white screen also.

    I dont know if theres anything else you'd like me to test, try out etc, etc, but thats what I've found so far, a few big issues, but its been pretty stable tbh.



  • @PhoenixLandPirat said in Testing the upgrade to Qt 5.12:

    The Gallery app shows images fine, but when I go to try and edit a image to crop, it turns black and doesnt give me the option to crop.

    OK. Trying to figure out what was going on here was weird, but it lead to some issues in ubuntu-ui-extras which I fixed, and then also a change in QFile::copy in newer versions of Qt apparently was resulting in apparmor denials.

    After upgrading the packages, and rebuilding the apparmor profiles (this can be done by running sudo aa-clickhook -f), it should be working again (it does here).



  • @dobey said in Testing the upgrade to Qt 5.12:

    After upgrading the packages, and rebuilding the apparmor profiles (this can be done by running sudo aa-clickhook -f), it should be working again (it does here).

    I trued updating by updating to the latest ubuntu ota, then repeating the instructions at the top, I rebooted and used sudo aa-clickhook -f and it didn't work, I tried the ubuntu-qa update command and it said everything was up to date, I tried to also use sudo aa-clickhook -f and see if it worked without rebooting, but that didn't work either, so perhaps there's extra problems with the OP3 and apparmor profiles?

    I discovered a few other issues, I'm sure that your fix for the editing pictures will probably fix this problem, but I couldn't view a downloaded pdf in the document viewer, firstly it wont open from the browser, but if you save it to the documents folder, than you can open it, but it's just a black page, and you can't view it unless you tap on slideshow view.

    Also the camera, if I try to take a photo, I get an error saying "Capture failed, restarting your device might fix the problem." it doesn't fix the problem, but its probably apparmor issues, that might be different on the OP3, than the devices that you're debugging on, or different between arm64 and armph?



  • @PhoenixLandPirat said in Testing the upgrade to Qt 5.12:

    I trued updating by updating to the latest ubuntu ota, then repeating the instructions at the top, I rebooted and used sudo aa-clickhook -f and it didn't work, I tried the ubuntu-qa update command and it said everything was up to date, I tried to also use sudo aa-clickhook -f and see if it worked without rebooting, but that didn't work either, so perhaps there's extra problems with the OP3 and apparmor profiles?

    OK, I'm not sure what wouldn't work here. Are there apparmor denials in /var//log/syslog that happen when you attempt to open the photo editor page? Do you have a log of the gallery app?

    I couldn't view a downloaded pdf in the document viewer

    Yes, this is because the PDF plug-in in docviewer is using private Qt API. I've just proposed a huge change to an updated PDF plug-in that was being worked on a few years ago, which removes the private API usage, and allows PDFs to work again on Qt 5.12.

    Also the camera, if I try to take a photo, I get an error saying "Capture failed, restarting your device might fix the problem." it doesn't fix the problem, but its probably apparmor issues, that might be different on the OP3, than the devices that you're debugging on, or different between arm64 and armph?

    I think the OP3/3t needs a different camera app and backend, which is not yet a default part of the system, to work properly, still. I don't think this issue is related to Qt 5.12. I don't have that device, though camera is working fine on my Nexus 4.



  • Nexus 6p here, just upgraded.

    Some of the reported problems works on my device:

    • App drawer looks fine
    • Camera works edit: Worked for a while, then the device lost connection to the camera. Not sure if it's qt related, but it hasn't happened before.
    • Editing images from the gallery app works (rotate, crop, brightness)

    What doesn't work that I've tested

    • TelePORTS: Blank screen
    • Calendar & Clock: Crashes on open (both load their interfaces before crashing)


  • @dobey said in Testing the upgrade to Qt 5.12:

    Are there apparmor denials in /var//log/syslog that happen when you attempt to open the photo editor page?

    Yes, it does give me some error's pastebin.ubuntu.com/p/zkpX8SVb8f/

    Do you have a log of the gallery app?

    I got a log for that at pastebin.ubuntu.com/p/5ZyYzmPg8b/

    I've just proposed a huge change to an updated PDF plug-in

    I got an email saying that you proposed a fix to replace the private API, and I thought, damn I was just 10 minutes to early, fantastic work from everyone who's worked on this all!

    I think the OP3/3t needs a different camera app and backend, which is not yet a default part of the system

    Maybe, IDK but the camera shows the preview, and can focus, it just doesn't save the photo when I press the button, and it hadn't been an issue before I updated to qt 5.12, but maybe when I install qt 5.12 it replaces the camera with a more mainline camera that doesnt work?



  • @potet said in Testing the upgrade to Qt 5.12:

    Calendar & Clock: Crashes on open (both load their interfaces before crashing)

    Do you have the log files for these apps for when this happens? Thanks.





  • @danqo6 OK, that looks like a problem with apparmor on that port. Do those apps work with current devel image? It seems like it should have the same issues.



  • Yes, all apps are working with updated system, it is treble OP3T port, but it was same with halium 7.1 port



  • @danqo6 Does the working version have those lines about /run/user/.... in the logs?



  • Calendar Both apps have it, apparmor errors looks similar too



  • @danqo6 OK. That's quite odd. Are there any apparmor complaints in /var/log/syslog when you start either of those apps?



  • I couldn't open the log in any app and am not really comfortabld in the terminal on phone, but here is what i found for the clock:

    From my syslog:

    674]: CachedAgent::authenticate_request_with_parameters: Application pid: 7235 Application uid: 32011 Application id:  com.ubuntu.clock_clock Cached request:   Request(from: com.ubuntu.clock_clock, feature: 0, when: 1601922651428171822, answer: granted)
    Oct 23 22:34:01 ubuntu-phablet dbus[2784]: apparmor="DENIED" operation="dbus_method_call"  bus="session" path="/org/gnome/evolution/dataserver/Subprocess/6270/2" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.85" pid=7235 label="com.ubuntu.clock_clock_3.12.5" peer_pid=6270 peer_label="unconfined"
    Oct 23 22:34:01 ubuntu-phablet dbus[2784]: apparmor="DENIED" operation="dbus_method_call"  bus="session" path="/org/gnome/evolution/dataserver/Subprocess/6346/2" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.88" pid=7235 label="com.ubuntu.clock_clock_3.12.5" peer_pid=6346 peer_label="unconfined"
    Oct 23 22:34:01 ubuntu-phablet dbus[2784]: apparmor="DENIED" operation="dbus_method_call"  bus="session" path="/org/gnome/evolution/dataserver/Subprocess/6270/3" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.85" pid=7235 label="com.ubuntu.clock_clock_3.12.5" peer_pid=6270 peer_label="unconfined"
    Oct 23 22:34:01 ubuntu-phablet dbus[2784]: apparmor="DENIED" operation="dbus_method_call"  bus="session" path="/org/gnome/evolution/dataserver/Subprocess/6270/4" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.85" pid=7235 label="com.ubuntu.clock_clock_3.12.5" peer_pid=6270 peer_label="unconfined"
    Oct 23 22:34:01 ubuntu-phablet dbus[2784]: apparmor="DENIED" operation="dbus_method_call"  bus="session" path="/org/gnome/evolution/dataserver/Subprocess/6270/5" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.85" pid=7235 label="com.ubuntu.clock_clock_3.12.5" peer_pid=6270 peer_label="unconfined"
    Oct 23 22:34:01 ubuntu-phablet dbus[2784]: apparmor="DENIED" operation="dbus_method_call"  bus="session" path="/org/gnome/evolution/dataserver/Subprocess/6270/8" interface="org.freedesktop.DBus.Properties" member="GetAll" mask="send" name=":1.85" pid=7235 label="com.ubuntu.clock_clock_3.12.5" peer_pid=6270 peer_label="unconfined"
    Oct 23 22:34:02 ubuntu-phablet dbus[2784]: apparmor="DENIED" operation="dbus_method_call"  bus="session" path="/org/g
    

    That's all that could fit on one screen, and I still haven't figured out how to open the menu that allows me to mark/copy text in the terminal app, so it's a bit of a struggle. Will trade more logs in exchange for tips on using the terminal! 😉


Log in to reply