Cannot get Lightdm to start / boot loop

  • Hi everyone!
    I'm trying to port to the nexus 5X (bullhead)

    When starting the device for the first time, i got stuck in a boot loop, probably because of LightDM crashing. Disabling autostart bu adding "manual" to /etc/init/lightdm.override solved this.

    Now i'm trying to find the cause of this problem, mostly by following the documentation.

    The Android container is running (checked with sudo lxc-info -n android)

    I've also checked mounted partitions.

    Wifi is working, so i have installed libc6-dbg and typed the following commands

    sudo unity-system-compositor --debug-without-dm &> ~/usc.log
    sudo gdb -ex 'set confirm off' -ex 'run' -ex 'bt full' -ex quit --args unity-system-compositor --debug-without-dm &> ~/usc-gdb.log
    sudo /system/bin/logcat -d &> ~/usc-logcat.log

    Then, after rebooting, and starting lightdm with sudo service lightdm start ,checked the logs and here is the content


    sudo: gdb: command not found


    usc-logcat.log :

    CANNOT LINK EXECUTABLE "/system/bin/logcat": "/android/system/lib/" is 32-bit instead of 64-bit

    The last one is kinda worrying 😃 i used the rootfs mentionned in your documentation

    I'm not sure where to llok next 😕

  • @pelomedusa Might well be not remembering correctly but think many have tried and given up on the Nexus 5x. There is a big reason why it is not supported just cant remember what . Sorry to have to give you that info.

  • Did you check if the /vendor partition is mounted correctly? Also, you probably need to change a symlink to get it into the right place. Plz join Telegram porting group, the forum i s not a good place to help you.

    So disabling lightdm is the right thing for the moment, but please try first to debug the Android container before you try anything else on UT side. In your case, we need a logcat, try LD_LIBRARY_PATH=/system/lib64:/vendor/lib64 /system/bin/logcat and then also EGL_PLATFORM=hwcomposer test_hwcomposer should run without a crash first

Log in to reply