OPO no more Internet

  • Hi, i have a OPO with 16.04 (OTA 12). Two days ago i bought and set up a new Router (FritzBox 7530).
    Connecting the Phone was no Problem, choose the right network/router, enter the PW ,done. Internet access via Router was working.

    Yesterday me and my phone left the house. Since we returned i have no Internet access via Router:
    First there was no network-icon. After choosing the Router in the settings the Network-Icon was there, but "empty", in the Settings it is said the network is "connected". After a short while i'm asked to enter the PW (again), but nothing changes. The Router says there is no connection to the Phone.

    I rebooted several times, "forgot" the Network, but no success. What to do next?

  • @nutzernam

    1. In the router setting [fritz.box/# in browser -> Wi-Fi -> Wi-Fi Network -> in the listing is your device listed either be it connected or non-connected?

    On that same page -> scroll down to 'Name wireless network',
    2. has your SSID changed since your last succesfull connection?
    3. And below SSID name, which of the boxes are ticked?

    1. In the router setting [frit.box/# in browser -> pw -> Wi-Fi -> Security -> scroll down to bottom which of the two boxes is ticked?

  • Whilst keeping your device next to the 7530 router and pressing+HOLDING (edit: for a few seconds) the 'connect/WPS' button on the router, does the indicator blink to then go steady and connecting?

  • Hi,

    1. The device was listed as "non-connected", i deleted the Device from the List and tried again, nothing.
    2. No, the SSID name hasn't changed
    3. "Networkname visible" is ticked
    4. "Allow all new Devices" is ticked.

    The Indicator on the router blinks, but no connection is made, i'm asked 3 times for the PW , then the indicator stops blinking.

  • Oke.

    1. Have you tried adding the device to the home network manually using the deviced MAC address?
      Home network -> [first tab 'Network connections'] scroll down to bottom -> add device

    Just to be sure,
    6. did you buy the router brand new or used?
    7. your password equals the one stated on the backside of the router?
    8. you don't have guest access enabled right? *[Wi-Fi -> Guest Access -> first box should be unticked in first instance when you bought the router as used

    1. Now i have, but it doesn't worked
    2. brandnew
    3. yes
    4. guest access is disabled

    Other devices (two pc, one mobile) are still connected from the beginnig till now

    1. If the devices MAC address is not listed underneath the overview of failed attempts either
      [Wi-Fi -> Wi-Fi Network -> section Known Wi-Fi connections -> subsection Show Failed Attempts]
      I think we can rule out the FritzBox!, especially since you mentioned another mobile phone can keep connection (no UT?)

    2. Connection diagnosis does not output any problems? [Diagnose -> Function -> press 'start'] and latest FW is Fritz!OS 07.20?

    3. If you want to know for sure the new router isn't the problem you could consider resetting it to factory settings
      [System -> Back-up ->(if needed follow back-up instructions, else:) last tab 'Factory Settings' -> load factory settings]
      and after re-establishing internet connection (Power/DSL and WLAN green and not blinking) you should be able to automatically connect your device to the wireless network by pressing/holding the connect/WPS physical button om your router.

  • FYI
    I noticed my OnePlus automatically connects with the 5 GHz frequency band while others are on 2,4 GHz
    [Wi-Fi -> Wi-Fi Channel -> Wi-Fi Channel setting]
    Automatically does work for my devices.

    1. No, there is no Device listed, the other mobile is an Android
    2. No problems listed,and its 07.20
    3. Since i doesn't changed anything (only renaming the Router before i connected the devices)...maybe when nothing else works

    Both frequencies are enabled, my pc is on 5GHz.

    First of all: many thanks for your time, do you have any other ideas? Is reflashing the mobile a reasonable option?

  • @nutzernam

    The one thing that has changed is the new router. As you mentioned in your OP you have been able to establish a succesfull connection initially.

    Presuming you haven't changed your device to another channel, Reflashing should therefore not make any difference imo.

    What happens when you change the connection of the Android device that is still connected? If you'd go into the phone's WiFi setting and 'forget' the current network connection to the FritzBox!, then turn off the Android phone and finally unplug the Fritzbox physically. Then after a few minuted plug in the router again, wait for the first and second indicator to be steady, before booting the Android phone. Curious to know if the Android will automatically detect and connect to the router again after having performed this hard reboot to the router. If not succesfully connected, we should definitely be looking into the FritzBox! settings again.

    In addition you coulf have someone else give temporary access to the new router (using the physical 'Connect/WPS' connecting method described above) and see what happens.

    As for the computets currently connected to the router, are they connected using WiFi too or by LAN?

  • Did you try to stop data connection? I sometimes have problems when switching from data to wifi and vice versa when both are on.

  • All Devices are WiFi connected. Only for setting up i connected my Laptop by LAN. There were no changes neither on the router nor the OPO while while i was out. The only thing: i used the OPO with data connection searching the internet.

    Currently the data connection is off ( i tried both ways) only WiFi is on.

    I will try the "Android Test " tomorrow.

  • Today i:

    1. Deleted the network on the Android Device and turned it off

    2. unplugged the router, waited 5 minutes

    3. plugged the router in and waited until both indicators (power/DSL and WiFi) were steady

    4. Turned the Android on.

    5. the network was visible to the Android, entered the PW and had internet access

    6. Load factory settings on the router 7530

    7. tried to connect the OPO with the router (which has now another name)

    8. failed to connect the OPO like before

    9. went in the basement, took the old router (7360)

    10. entered the PW of the old network on my OPO, had access

    I bought the new router because i had trouble with randomly failing connections to DSL.
    My provider said its not his fault, my eyes said its not my cable, so i thought: try another router.
    In the morning not only my OPO was a real pain, but also the DSL connection failed more than ever…So tomorrow i will return the 7530. Meanwhile i enjoy surfing on the OPO using the old router until DSL fails again.

    Many thanks for your time!

  • YMW,

    Sorry to hear that you have (had) that much trouble. If the seller can swap the router that would be great. I'm on FritzBox! 7590 and everything works fine.

    Good luck!

Log in to reply