Need help to flash Meizu5 pro originally on Android. Problem with the cache partition



  • @mlinodasilva Ok, let's try something else here.
    Install TWRP recovery, wipe it all clean, download my backup of Ubports_ota1.zip from : https://drive.google.com/file/d/0B1z6xtxx8BDjVFQ4czZmbzhwWjg/view?usp=sharing
    unzip it, and restore it with TWRP.
    It's a fresh, clean, formated install of Ubports_ota1. Then just flash recovery-turbo.img. Then

    Hope it works. ( I did once the same time when I had a similar problem and then it all works like a charm) Fingers crossed.



  • @mlinodasilva if you search xda site for multirom v33 ,there is a link for all the bits and pieces of pro 5 (when using fastboot i always have to use sudo , or nothing happens)



  • This post is deleted!


  • @mlinodasilva Just try to restore that backup of mine and let me know how it did go.



  • @Stefano That worked thank God!! I had an additional difficulty the recovery couldn't flash the data partition for some reason so I reformated it, I suspect the issue might have been lying there. For the sake of it I tried ubuntu-device-flash and it still didn't work, but this time he got stuck on a progress bar.

    Anyway I flashed all the partition images you sent me, and soon enough I had ubports booting!

    I cannot state how much I am grateful for your help, you have been most kind in helping me, I was going nuts oer this. THANKS!

    Now I just have to figure out how to make my SIM work again (I never could get it to work in anything else than the slim slot with the canonical image, and now it doesn't seem to recognize the sim in any of the two slots, but thats probably an hardware fault I have had since the beginning, these meizu 5 phones are known to have random hardware issues).

    In any case, I have internet, camera, and hopefully GPS already working, so it's already a nice start. Thanks again Stefano!



  • @mlinodasilva Very nice indeed, that @Stefano was able to help you to get ubports onto your phone! 🙂

    I'm thinking that it is probably not only you having this problem so now when you have both his working files and your non-working files in the cache, could you try to compare to see if you can find something that looks wrong about them? In particular the files keyring and image-master files that looked strange in your log print would be interesting i think.



  • @hans1977se I can upload my /root/.cache/ubuntuimages I haven't deleted it yet, would that be of interest?



  • @mlinodasilva Sure. Why not. More people will be able to compare then. Could be a good idea to limit the size if there are obviously unrelated files, though. 🙂



  • Update: Don't try to rsync your old canonical home folder in ubports, everything gets stuck, I'm in the middle of wiping my data folder and reflashing again 😛

    It's gonna be a pain in the ass re-importing the contacts, calendar, etc... is there a list of the relevant hidden folders anywhere?



  • @mlinodasilva Copy the .local/share/history-service/history.sqlite, the .local/share/evolution/addressbook/system/contacts.db and your camera pictures. Should take you quite a step, hopefully.





  • @mlinodasilva I would wipe all partitions apart from ExternalSD ( not rm -rf, but wipe in setting of TWRP)
    Then I would do fastboot -w, reboot to recovery,
    then I would flash Flyme - the one you flashed when converting from a to i/g firmware. IT might show some errors, but it will flash successfully.
    Unlock the bootloader if it gets locked again.
    Start the Flyme, enable the Developer options + Usb debbuging.
    Reboot to fastboot, flash TWRP recovery.
    Reboot to recovery, wipe ( not rm -rf ) all partitions apart from ExternalSD.
    Now reboot to fastboot and flash recovery-turbo.img
    Reboot to recovery
    In terminal type: adb devices if it list your device.
    Now try ubuntu-device-flash..... again.



  • @Stefano this is to try to solve the issue
    With the phone not detecting the SIM card? Did anyoneelse have this issue in the past?



  • @mlinodasilva What happened that your phone doesn't recognise sim cards? In settings, are there an IMEI numbers or is it says None?
    This might help to fix the issues with the partitions on your phone, since you have some glitches there, so maybe a complete wipe + factory reset + flashing Flyme and later Ubports might be a sollution.
    Not sure about the recognising the SIM, but give it a shot.



  • @mlinodasilva I forgot to tell that rsync between my Nexus 4 with Canonical image and Nexus 5 with ubports image works for me.



  • Heh, it seems I have a string of bad luck regarding this phone (in between the hassle it was getting it from China, then flashing canonical ubuntu, then breaking the screen, trying to get a replacement one, the ubports).

    I tried anther chip and it works, so for some reason my SIM is malfunctioning, will get a replacement one...

    I've been slowly reinstalling stuff, I noticed that the GPS has trouble working, although it seems to be recognised, but I remember it was already difficult when indoors during the days of canonical. Accelerometer works, but the compass app doesn't seem to be working. Minor hurdles...

    Anyway, by request I uploaded my ubuntuimage folder from /root/.cache the link is below:
    https://www.dropbox.com/s/0464g6vpm6kzgsb/ubuntuimages.tar.gz?dl=0



  • @mlinodasilva where would you get a replacement chip/motherboard from? I'm interested to buy one, if there is a good price? Let me know, please?



  • Sorry for not being clear, by 'chip' I meant the SIM

    Anyway I can share my experience with ordering my spare screen: As you can imagine, it was not easy. First of all Meizuworld was a no go, they don't seem to accept orders from outside China. So I registered an account in aliexpress and made a search for a replacement screen. I was a bit weary from ordering from some random supplier there so I decided that I would pay through paypal to have some sort of protection. This already limited my options since most of these China suppliers don't accept paypal. Still I was left with about 10 stores with an acceptable range of prices. Then I put orders for the screen with int. Shipping and in 3 cases I got refunded and my order cancelled with no explanation. At the 4th attempt a supplier from Hong-Kong did ship it. 1week attempts at purchasing plus about 3weeks shipping (with very nice tracking and packaging). I also ordered a plastic case for my phone from another supplier using the same method. doing

    This is what I would suggest doing, but it takes time...



  • I have some more questions regarding Meizu on ubports:

    1. If I place a phone call I cannot hear anything unless I plug the phones or put it on loudspeaker? Is this a bug or do I have to put some feature on somewhere in the options?

    2. The calls and ams scopes no longer exist? They were very useful... How can I get a listing of the phone calls history with ubports?



  • @mlinodasilva I have not such a problem with sound, but other users reported that already. So yes a bug.

    You can still install some scopes from Canonical Ubuntu store. Maybe not all, but most yes.


Log in to reply