Question about strange Signal/Axolotl issue

  • One of my contacts sent me several text messages and a lot of separate sent photos from his Android phone via the official Signal app.

    He said some appeared as 'sent' (two dots with v), some 'sending', others had a sent status, but when checked again didn't have it anymore.

    I think I received all his text messages, but I am certain I did not receive all the photos. Later, the same happened with the same contact. Also, some photos were delivered to me hours later. All the time, my phone had connection (I use 2G and 3G, switching to wifi offered no solution).

    What I would like to know if this is an issue of the sender's phone or if it can be caused by the receiving phone: my phone with UT and Axolotl?

    First, I thought it must be the sender's phone, but then he said sent status changed.Also, I opened Axolotl today, and got a message ' Your registration is faulty. Please consider to register again'. This message was gone after re-opening the app. From other contacts I succesfully received messages afterward, although one arrived late.

    I must say I often activate flight mode, and I switch on mobile network several times a day for a few hours. I don't want to be online all the time. I have standard UT firewall enabled. This has worked for me up till now.

    As I am unsure if this is an Axolotl issue, or something on the sender/server side, I am posting this as question not Github bug report.

  • @Alter hello and thank you for opening that topic. We definitely need to investigate before being able to answer you. For that, we need the logs of Axolotl, which are located in .cache/upstart/application-click-textsecure.nanuc_textsecure_0.8.9.log if you are running the last version. Do not post them here raw, there is private data in it. Either remove phone numbers from the log or send us privately on telegram (flaburgan and nanu-c).

    For your information, I also had the "registration faulty" popup so I will also investigate this problem.

  • @Fla I installed the Logviewer app and have found the log, but how do I copy, edit, export?

    Are phone numbers the only sensative data in this log, or do I need to delete more parts?

    Is it safe to post it, with only phone numbers deleted, on or the like?

    I haven't used Teleports yet,, but apparently one cannot join groups or persons without mobile number.

  • @Fla : I didn't expect this, but after a secure session reset from my side (in Axolotl : click on contact > menu dots in right upper corner > restore key (or something similar, I don't use English version so I translated it), there was reliable communication again, meaning both sides received each others messages without loss. Strange, as I would have expected the sender phone/network to be causing problem. I did not see the message 'your registration is faulty' anymore.

  • the button on the top right corner of the Logviewer allow you to directly publish the log on

  • @Fla When I click that button, does it still give an option of editing before publishing? You told me that I shouldn't upload the log in its original state, as it contains sensitive data. I don't want to publish by mistake. Are phone numbers the only data that should be deleted? And, are the logs still useful after a secure session reset that apparently solved the problem?

  • I think that phone numbers are the only sensitive data yes. Not sure the logs are still useful.

Log in to reply