Meizu Pro5 fastboot mode locked



  • @Stefano said in Meizu Pro5 fastboot mode locked:

    @halucigenia you just plug the phone to PC and copy the update.zip to your sdcard(internal storage) not to any folder, just to sdcard. Then when rebooted to recovery and select: SYSTEM UPGRADE and also CLEAR DATA (the phone will look up the update.zip and will wipe the phone as well so save your data somewhere else)
    It takes some time to update it and then reboot
    Once in Flyme, enable developer options, usb debugging.
    Reboot to fastboot and type : sudo fastboot oem unlock

    Reboot the bootloader to check if it says ,,unlocked''
    From there you can try direct flash either with Ubports installer, MDT or terminal command.
    Good luck.

    Stefano stated "you just plug the phone to PC and copy the update.zip to your sdcard(internal storage) not to any folder, just to sdcard."
    And another piece of the jigsaw comes into place.
    I will get a nice shiny new micro SD card on the way home just for this.

    Thank you very much Stefano. 🙂



  • @halucigenia no my friend, not to externalSD card, just to your phone storage (hence sdcard/internal storage) , not to any folder, otherwise the recovery won't find it.



  • @Stefano said in Meizu Pro5 fastboot mode locked:

    @halucigenia no my friend, not to externalSD card, just to your phone storage (hence sdcard/internal storage) , not to any folder, otherwise the recovery won't find it.

    Thanks, I was confusing the terminology, SD card to me means something different to internal storage.



  • Well, it turns out that I do have a Chinese version Pro5.
    I thought that since I did have an English GUI that it was international.
    I even reset to factory settings again and went through choosing English language again to confirm this.
    Trying to install the update.zip returns a "Firmware Corrupt" message.

    Once I managed to root and install the android term app
    I saw that using
    cat /dev/block/platform/15570000.ufs/by-name/proinfo from the androidterm app
    it listed
    machine_type=M576_mobile_public
    Which according to the xda tutorial means Chinese

    after following the instructions from
    https://forum.xda-developers.com/meizu-pro-5/how-to/tutorial-change-region-id-to-t3323883
    this changed to
    machine_type=M576_intl_official

    However, even after following those instructions I still can't get the update.zip from xda to install.
    Trying to install the update.zip still returns a "Firmware Corrupt" message.
    The update.zip from Stefano also results in a "Firmware Corrupt" message.



  • @halucigenia You did not installed the correct Terminal app and/busybox app, therefore the changes are only temp and after reboot it rolls back to chinese.



  • I have just retried from scratch again and made sure that Flyme OS 5.1.3.0A was installed first, which I may have missed last time.
    I now have an un-locked bootloader in the flyme version downloaded from xda.

    I am just starting to follow the procedures here:-
    https://forums.ubports.com/post/4929
    as neither Ubports installer or MDT seemed to allow a Pro5 install and phablet-tools seems to be unavailable on Kubuntu 17.10.

    @Stefano Please let me know if those instructions should now work for me.



  • @halucigenia did you downgraded the Flyme to that version mentioned in that post? Newer versions of Flyme were patched by Meizu to prevent the unlocking of bootloader and chnging ID to Global/International.



  • @halucigenia oh yes, that's correct. That is my backup of Ubuntu-touch/15.04/stable/r1(ota-1).
    Just follow the steps and it should work.



  • @Stefano OK I tried, but each time I installed the zip file it returned errors:-
    "Could not find 'META-INF/com/google/android/update-binary' in the zip file"

    What do I do now?



  • @halucigenia You need to unpack/unzip it and then to restore the backup. I had to compress it when I uplodaed it.



  • @Stefano OK, I now have the folder Ubports_ota1 in /sdcard/TWRP/BACKUPS
    and can navigate to it but it won't let me proceed - there is no option to install after selecting the folder.



  • @halucigenia Restore backup, not install
    Rebbot recovery first



  • @Stefano said in Meizu Pro5 fastboot mode locked:

    @halucigenia Restore backup, not install
    Rebbot recovery first

    Ah, OK, got it. But it had to be copied to the /sdcard/TWRP/BACKUPS/M86 directory before the restore function could see it.



  • @halucigenia As I said, follow the steps provided.
    Once you've done it, there is an update available, but it only will be installed after you flash the ubuntu recovery. fastboot flash recovery recovery-turbo.img

    Let me know if you succeeded.



  • @Stefano installed and updated to UBports v2.

    Thank you so much for your help.



  • @halucigenia Enjoy the Ubuntu Touch on your Pro 5 🙂



  • If I get the chance I will see if I can compile an instruction set for a step by step how-to.



  • I am glad for you! 🙂 Congratulations for not giving up! It took me about three days to do it a year ago... Welcome! 🙂



  • Hi,
    thanks for ubuntu touch, I had same problems with a meizu pro 5 with flyme 6.0.0G firmware installed. I solved installing previous flyme firmware from here:

    http://dl-res.flymeos.com/Firmware/Flyme/PRO_5/5.1.11.0G/intl_stable/20161028020453/22a9e4dc/update.zip

    then I installed beta firmware from xda developer site and I unloked the bootloader.



  • Hi all.
    I read with interest this thread. I got a Meizu Pro 5 just one week ago and since then I'm struggling to make it eligible for UT installation.I guess it's a chinese version, since it is coming from China and when I first booted it up, it showed up a lot of chinese app. The main problem I'm facing is that the OS arrived locked and when I go into fastboot mode the device is not detected by the Desktop terminal and I cannot unlock it.
    Therefore, I followed all the useful threads indicated here but without any luck up to now. Here following the steps I made:

    1. To double check the version I typed the following:
      0_1526921218326_cff85a8d-aabd-456d-b30b-732f1adc00f1-image.png

    As you can see I got a [none] which sounds very strange to me.

    1. I then tried to change the region:
      • I installed the chinese Flyme OS 5.1.3.0A and then, to get root, I installed KingRoot, which does pretty well the job to gain the root access;
      • then I installed SuperSu 2.76 (by Chainfire) and BusyBox v1.24.1-meefik. The installation from apk went smoothly but if I open each app by tapping on it, it states it cannot install the binary.
      • BTW if I enter the root mode, I can follow the next step without any issue:
        0_1526920854109_0c2e9f20-9a4f-4bd8-8d83-6ce7da939eaa-image.png

    The "machine_type=M576_intl_official" specification to make the phone international seems properly set. However, If I reboot the phone, and I type again "su", "id" and "cat /dev/block/platform/15570000.ufs/by-name/proinfo" I don't see anymore the specification above. It seems like if the "busybox cp -f" doesn't take effect at all and the modification is only temporary. Can you give me some advice on that, please? Any hint would be highly appreciated.

    Thanks,

    Matteo


Log in to reply