Meizu Pro5 fastboot mode locked

  • @matteo one hint from @Marathon2422 ( I was doing that automatically)

    If there is trouble to have your phone recognize with adb, then reboot the phone to Ubuntu Touch and unplug it from PC. In terminal (on PC) type:
    sudo adb kill-server
    sudo adb start-server

    Plug in the phone, on the screen should appear a small window to allow adb usb debuggingusb, click on to allow.

    Your phone (curent installation of Ubuntu Touch will remeber your PC and will allow the adb usb debugging)

    Reboot again to recovery and try Ubports installer or ubuntu-device-flash

  • @stefano I did it Stefano! I followed step by step your guide to resize the cache partition and now I have the 16.04 UT installed! Thank you so much, you were very helpful! I would like only to take the advantage of this open thread to share some thoughts about the newly installed OS:

    1. I tried to install back the Ubuntu recovery by typing "sudo fastboot flash recovery-turbo.img" but now, inaspectedly respect to when I did the same for the 15.04 working flawlessly, now I got this error:


    Just to be clear, the file is in the $home folder, the name of it is "recovery-turbo.img" and I enabled the developer mode.

    1. However, is there a reason why I should install the Ubuntu recovery? Doesn't make any sense to stick with the TWRP recovery, in order to be ready in case of any problem and restore for instance the backup?

    2. Both with the 15.04 and now with the 16.04 I noted that my home wi-fi session is not keeping the password, which I have to reinstate every time I reboot the phone; I searched for a known bug on the UBports github and on this forum but unluckily I didn't find a thing about it. Do you know how to fix this problem on my Pro5?


  • I think I can reply to myself for point 2: if I try to update the OS and I download and install the OS update, the phone tries to boot to the Ubuntu recovery but instead boots to TWRP and there it just stuck and doesn't continue anymore the updating process.
    That's why I need the Ubuntu recovery, but up to now I'm not able to flash it again for some reasons it seems....

  • @matteo Congerats!

    reinstall the recovery by this command:
    sudo fastboot flash recovery recovery-turbo.img

    Yes it makes sense to have Ubuntu recovery installed for OS updates. If you just want to test it, then no.

    The wifi problem I never experienced on Pro 5, only on Nexus 5.
    I would probably wipe the phone completely, install Flyme 5......daily (the one for unlocking bootloader)
    And try again with Ubuntu aftrwards. Your partitions should stay untouched, ready for 16.04.

    I don't think that anyone mentioned that wifi bug on Pro 5, so probably just a glitch.

  • @stefano ahahaaha so I missed the command 'recovery' there.....yes, it works now 😜
    For the wifi then you are suggesting to install Flyme again ....ok I'll try that also, if I see the wifi problem persisting even after the latest update.

    Big thanks to all you guys who helped me so much! This community is awesome!



  • @matteo No problemo, I got helped, so I do help others.

  • @matteo regarding the wifi
    ,my bqm10fhd has this problem
    Caused by the flash tool,and my error.
    If you go back to android it will show NVRAM error x10.
    But it will remember passwords ,on android.

    I do not have this on my pro5

  • Unfortunately I flashed Flyme and then back to UT 16.04 but nothing, the wi-fi doesn't keep the password and at every reboot I have to reinstate that: it is so annoying. In Flyme it worked as expected, by the way. I suspect that also the GPS doesn't work because before, when I flashed for the first time the UT 15.04, both the wi-fi and GPS didn't worked as expected (I left the GPS looking for my position for 10 minutes or so and then I gave up). But here in 16.04 I found out I cannot install the uNav app yet, so I cannot check it.

    @Marathon2422 When I flashed the Flyme OS I didn't see such an error you are mentioning, so I don't really know what's going on with my Pro5. Am I the only one to have experienced that? Really weird...

  • @matteo I have uNav installed on my xenial device and also sensorsstatus. Both are versions for vivid, that's true, but they seem to work and at least those apps don't crash. Enough for me until there's a proper xenial version.

    For your wifi password you should file a bug report if it isn't filed already (use the Label button to look for issues specific of your phone).

  • @matteo Maybe download latest Flyme (International,Global ) unzip the file, remove bootloader file from there, create a new without bootloader file as this way you won't need to unlock it again) , flash it with Meizu Original recovery,( Wipe as well) enable Developer options, usb debugging, flash TWRP recovery, wipe it and try it again.
    Otherwise I'm out ideas what to do to make the wifi works.

  • @stefano Stefano thanks but it's not only the wifi. I just tried the sim card and it doesn't work as well. It's only 10 minutes I'm playing around with the 16.04 version and I stepped into several issues, for instance: the browser doesn't load a newspaper page throwing an error; if I select the printer option the system settings window freezes; transparency of the keyboard doesn't seem to properly work. I know that most of them are related to the status of the OS so I don't bother at all. It's the connectivity which bothers me and seems completely broken. However, I'll try to follow your hint and to keep flashing back to Flyme and forth to UT.

  • @advocatux how could you do that? I don't see in the list of OpenStore neither uNav nor sensorstatus...By the chance, do you have the click files?

    For sure I'll file tickets on Github, once I'm sure my problems are not related to maybe some mistakes I made during the flashing process as Marathon was suggesting...the reason why I wanted to go with the 16.04 OS was also to help improving it in some ways...

  • Sounds like a dirty flash from 15.04 /to 16.04.

    I did this and had the extra vivid apps.
    After a fresh install they were gone.

    Just my 2cents

  • @matteo for testing purposes, you can download any app from the OpenStore to your device, and then run on the terminal
    pkcon install-local --allow-untrusted path_to_the_click_package

    These are the urls for those packages:

  • @advocatux
    Gps works on 16.04. ?

  • @marathon2422
    Not on the Pro 5, "GPE denied".

  • @stefano I don't have any idea on how to flash the Meizu Original recovery starting from the files you uploaded, since it doesn't seem to be in the recovery folder an .img, would you please be so kind to give me any hint on how to proceed? I tryed to find on the internet the answer but without any luck, up to now. Thank you.

  • @matteo Download it from this site: link text is the file you're looking for. In TWRP flash the zip.
    I might have a look on my PC for recovery.img file when I get home.

  • @matteo here you go: FLYME RECOVERY

    Flash it with : sudo fastboot flash recovery recovery.img

  • Guys, below my latest attempts.
    I installed the latest Flyme Global version and the wi-fi worked good, remembering the credentials at each re-boot. However I had to install the older Flyme version with the unlocked OS, since this version seemed locked even extracting the recovery.img file as per Stefano suggestion. Also for this Flyme version the wi-fi worked as expected.
    Then, I flashed back TWRP in order to flash the UBPorts 15.04 OS OTA 1 following all the steps I knew already.
    The installation went flawlessly but I noticed the wi-fi losing the password at each re-boot and that the GPS wasn't working at all (checked against installation of SensorStatus and the weather default app).
    I then decided to update to OTA 3 to see if the behaviour was the same or not: same, wi-fi lost the password at every re-boot and GPS was just dead.
    After that, this time, instead than exploiting TWRP to flash the 16.04 image, I wanted to try a different route using the ubports-installer-0.1.12-beta-x86_64.AppImage installer; except for the manual initial triggering, then it worked great and I succeeded to flash the 16.04 OS.
    Now I have the 16.04 OS installed but still wonky: wi-fi doesn't keep the password and GPS is not working.
    I don't know what could be and why the behavior is so different from Flyme to UT but this is it.
    The only reason that comes to my mind is that I probably messed-up with the file system resizing in view of the 16.04 installation, but how? It's a pity because I really like the OS but in this condition it's just not possible for me to be used as a daily driver, not even with the 15.04 version 😞

Log in to reply