Meizu Pro5 fastboot mode locked

  • @matteo regarding the wifi
    ,my bqm10fhd has this problem
    Caused by the flash tool,and my error.
    If you go back to android it will show NVRAM error x10.
    But it will remember passwords ,on android.

    I do not have this on my pro5

  • Unfortunately I flashed Flyme and then back to UT 16.04 but nothing, the wi-fi doesn't keep the password and at every reboot I have to reinstate that: it is so annoying. In Flyme it worked as expected, by the way. I suspect that also the GPS doesn't work because before, when I flashed for the first time the UT 15.04, both the wi-fi and GPS didn't worked as expected (I left the GPS looking for my position for 10 minutes or so and then I gave up). But here in 16.04 I found out I cannot install the uNav app yet, so I cannot check it.

    @Marathon2422 When I flashed the Flyme OS I didn't see such an error you are mentioning, so I don't really know what's going on with my Pro5. Am I the only one to have experienced that? Really weird...

  • @matteo I have uNav installed on my xenial device and also sensorsstatus. Both are versions for vivid, that's true, but they seem to work and at least those apps don't crash. Enough for me until there's a proper xenial version.

    For your wifi password you should file a bug report if it isn't filed already (use the Label button to look for issues specific of your phone).

  • @matteo Maybe download latest Flyme (International,Global ) unzip the file, remove bootloader file from there, create a new without bootloader file as this way you won't need to unlock it again) , flash it with Meizu Original recovery,( Wipe as well) enable Developer options, usb debugging, flash TWRP recovery, wipe it and try it again.
    Otherwise I'm out ideas what to do to make the wifi works.

  • @stefano Stefano thanks but it's not only the wifi. I just tried the sim card and it doesn't work as well. It's only 10 minutes I'm playing around with the 16.04 version and I stepped into several issues, for instance: the browser doesn't load a newspaper page throwing an error; if I select the printer option the system settings window freezes; transparency of the keyboard doesn't seem to properly work. I know that most of them are related to the status of the OS so I don't bother at all. It's the connectivity which bothers me and seems completely broken. However, I'll try to follow your hint and to keep flashing back to Flyme and forth to UT.

  • @advocatux how could you do that? I don't see in the list of OpenStore neither uNav nor sensorstatus...By the chance, do you have the click files?

    For sure I'll file tickets on Github, once I'm sure my problems are not related to maybe some mistakes I made during the flashing process as Marathon was suggesting...the reason why I wanted to go with the 16.04 OS was also to help improving it in some ways...

  • Sounds like a dirty flash from 15.04 /to 16.04.

    I did this and had the extra vivid apps.
    After a fresh install they were gone.

    Just my 2cents

  • @matteo for testing purposes, you can download any app from the OpenStore to your device, and then run on the terminal
    pkcon install-local --allow-untrusted path_to_the_click_package

    These are the urls for those packages:

  • @advocatux
    Gps works on 16.04. ?

  • @marathon2422
    Not on the Pro 5, "GPE denied".

  • @stefano I don't have any idea on how to flash the Meizu Original recovery starting from the files you uploaded, since it doesn't seem to be in the recovery folder an .img, would you please be so kind to give me any hint on how to proceed? I tryed to find on the internet the answer but without any luck, up to now. Thank you.

  • @matteo Download it from this site: link text is the file you're looking for. In TWRP flash the zip.
    I might have a look on my PC for recovery.img file when I get home.

  • @matteo here you go: FLYME RECOVERY

    Flash it with : sudo fastboot flash recovery recovery.img

  • Guys, below my latest attempts.
    I installed the latest Flyme Global version and the wi-fi worked good, remembering the credentials at each re-boot. However I had to install the older Flyme version with the unlocked OS, since this version seemed locked even extracting the recovery.img file as per Stefano suggestion. Also for this Flyme version the wi-fi worked as expected.
    Then, I flashed back TWRP in order to flash the UBPorts 15.04 OS OTA 1 following all the steps I knew already.
    The installation went flawlessly but I noticed the wi-fi losing the password at each re-boot and that the GPS wasn't working at all (checked against installation of SensorStatus and the weather default app).
    I then decided to update to OTA 3 to see if the behaviour was the same or not: same, wi-fi lost the password at every re-boot and GPS was just dead.
    After that, this time, instead than exploiting TWRP to flash the 16.04 image, I wanted to try a different route using the ubports-installer-0.1.12-beta-x86_64.AppImage installer; except for the manual initial triggering, then it worked great and I succeeded to flash the 16.04 OS.
    Now I have the 16.04 OS installed but still wonky: wi-fi doesn't keep the password and GPS is not working.
    I don't know what could be and why the behavior is so different from Flyme to UT but this is it.
    The only reason that comes to my mind is that I probably messed-up with the file system resizing in view of the 16.04 installation, but how? It's a pity because I really like the OS but in this condition it's just not possible for me to be used as a daily driver, not even with the 15.04 version 😞

  • @matteo When using android ~ did you get a wifi called "NVRAM error+ 10"
    It can be caused by using flash tool. and wiping / formating the nvram
    This happens with BQ devices.
    Is it possible you wiped yours thru TWRP. ???

    Can you restore from backups,everyone makes before installing Roms.


    This guy has a lot of pro5 files linked from here
    Just put the http in

  • @matteo That's strange, I never had a problem with wifi, nor gps on 15.04.
    Regarding the Flyme Global, if you unpack the and remove the file called ''bootloader'' , repack the files to '''' again , you'll get the Flyme update zip, that don't need the unlocking the bootloader again. Also you can always wipe the phone with TWRP and flash the with it as well. I just thought that original Flyme recovery might do a better job to properly wipe and upgrade the phone base.
    Maybe there are some other Pro 5 users that could help as I'm unable to help in this case.

  • @matteo I don't know if this will help but there is a method to update just the baseband on a Pro5.
    Update Meizu Pro 5 Baseband

  • @matteo Duknow ab the GPS side but the Wifi connections are apparently stored in files at /etc/NetworkManager/system-connections/<AP Name>

    Check if this accessible and writable:
    drwxr-xr-x 2 root root 4096 May 27 16:36 system-connections

    It looks like mounted to userdata somehow:
    phablet@ubuntu-phablet:/etc/NetworkManager/system-connections$ df -h .
    Filesystem Size Used Avail Use% Mounted on
    /dev/disk/by-partlabel/userdata 54G 32G 22G 59% /etc/NetworkManager/system-connections

  • I am curious
    I am using pro5 16.04 as a daily driver,( i am retired,so just playing really), I find that i get a wifi password screen on top of the,login screen, all i do is cancel the Wifi screen, then login. If my wifi does not login,( and i will be using cell data) i pull up the wifi screen,and press once on my wifi,and it signs me in.

    ( without reentering my password).

    I am not aware that Gps,is working yet,

    Any similarities ???

  • @marathon2422 I didn't notice that wrong wi-fi name when I was on Flyme, no. However, also the GPS seems wrong. I followed all the steps to resize the file system and I didn't get any error. Thanks for the link, I'll have a look at it!

Log in to reply