Android mobile device hell (porting halium to Galaxy S7)



  • Ok, so I currently use one of the BQ Aquaris E5 devices still with the Ubuntu image as my main mobile device, and it is starting to really really go on my nerves. And I guess that would not change if I reflash with UBports as the main problem seams to be the hardware which has even serious issues handling the sqlite file for the message app...

    So I have this Samsung S7 lying around here with some horrible firmware of some local provider which looks like an store front O.O. I got that for almost free from the carrier and the plan was to use it for a project for a few months and that is now done and over and I have the device to do something else, like porting UBports to it.

    I have never done something like this before and my first Idea was to get a feeling how you flash the device and get some already working custom rom onto the device. I tried a Lineage OS rom and I'm already stuck pretty early because "download mode" refuses to accept the rom because of "Blocked by FAP lock".

    So I tried to google it and fucking hell... it is completely impossible to find any useful information about the issue with a search engine, or I don't have the correct search term to look after the actual problem. I just get a lot of noise about computer voodoo and no actual answers.

    So hopefully someone here can point me into the right direction. What am I actually dealing with? I this some kind of hardware lock or is it part of the download firmware? Is there any documentation anywhere about stuff like this?


  • Community

    I'm not really sure what the steps to fix the issue are, but searching the Internet leads me to believe that the A is actually an R, and it says "Blocked by FRP lock".

    That font is really poor.



  • Samsungs are notorious for the hoops you have to jump through to unlock the bootloader to be able to flash alternative images in it. Especially if you don't have a Windows (virtual)machine to do the unlocking on...
    Did you already check in the relevant threads on XDA developers?



  • Ok, found it out, was indeed an R not an A, that really is some poor font there.

    The problem was solved by booting back into the original image and enabling "non OEM" images in the developer mode settings which you only see after tabbing 7 times onto the os version number somewhere in the settings (seriously, wtf). Now I can successfully flash my own images on it.

    Thanks for pointing me into the right direction :-)


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.