Installing on Nexus 5



  • @tupp

    You only have to check "Updates available" in "System Settings" on your Nexus 5


  • Infrastructure

    Yes you need to visit system settings and then the update icon from time to time. We will enable push notifications eventually again when a new OTA is out. This worked at Canonical times but then ceased, no one knows why...

    BR



  • Okay. I will check for an update after I get my phone up and running with a carrier.

    Thanks!



  • Hi! I only could install UT by CPT. The snap package hasn't been found on Ubuntu... And it doesn't work by magic-tools .. My installation (or re-installation) is 2 days old ;)



  • Hi

    I would like to also ask for a little help.

    I am completely new to android flashing. I just got second-hand nexus 5 32GB and wanted to try ubuntu touch. I was able to make first steps and ubports-installer proceeded at first - then it was wainting for device to enter recovery mode. It actually always stops there. I can get to ubports recovery but there are too many options.
    Reboot system now
    Ubuntu actions
    Android actions
    Reboot to bootloader
    Power down
    View recovery logs
    In ubuntu actions are following steps:
    -replace ubuntu android system
    -install ubuntu zip
    -install ubuntu preinstalled
    -wipe data/factory reset
    in android actions are following options:
    -apply updates
    -wipe data/factory reset
    -wipe cache partition
    -wipe media

    I have 5 recovery logs
    /cache/recovery/last_kmsg
    /cache/recovery/last_log
    /cache/recoverylast_log.1
    /cache/recoverylast_log.2
    /cache/recoverylast_log.3

    Does the logs signal any possible problem?

    I have a few question about my situation

    1. Am I on a right track? can I safely proceed with installation and how?
    2. Can I safely roll back to android at this state? How could it be done?
    3. Is it now late to back up data for possible future recovery? I was a little too quick - I thought that gui installation would be straight forward so I was proceeding with not that much care.

    Sorry for long message I wanted to specify as much as I could on the first time. Please help me - I really would not like to screw the phone.

    Thank you in advance for your help
    Andrej



  • I just want to add - the phone itself always shows only the google logo with a lock at the bottom just as tupp reported previously.

    Thanks again
    Andrej



  • @andirs26

    When you see that recovery screen, DON'T DO ANYTHING! -- it is installing Ubports!

    I know it is very confusing to see that "recovery" screen appear during an installation, but you are golden. Just let it do it's thing.

    By the way, if your phone is not getting past the Google logo/lock, connect your phone to your computer, and in a terminal try "fastboot oem unlock". If the fastboot screen appears on the phone, start the ubports-installer.

    Sorry that I forgot to be explicit in my post above that I did nothing when the recovery screen appeared and then the os installed. I have added that "detail" now, thanks to you!



  • Thank you so much. I am happily writing this message,from Ubuntu touch. The process was fast and automatic from that point. Everything seems to work. I had only one problem with browser the at first it was not accepting ssl certificates. Then I found out that time was not synchronized from wifi maybe it is synchronized only from operator by default. But I first booted without sim card. Because of wrong time browser considered certificate dates as invalid so the problem was easily fixed.

    Thanks again for great support.
    Andrej



  • By the way can I and should I OEM lock the phone now?



  • @andirs26

    I don't think that one can "re-lock" their phone to a particular carrier. Furthermore, there probably is no need to do so, as carriers generally use a phone's IMEI or ESN number to accept or reject a phone. From what I can tell, carriers don't to discern whether a phone is locked or unlocked.

    Enjoy your Ubuntu Touch phone!


  • Community

    Also, if you do oem lock at this point, the device will be wiped. All Ubuntu Touch data, including the OS itself, is in the /data partition. This is not the case for devices that shipped with Ubuntu Touch from BQ and Meizu.



  • @unisuperbox
    Thank you for that information. I am happy that I did not try it before I saw your post. By the way does it mean that android binaries are still there on another partition? I just wonder if it booted to android if I locked it.


  • Community

    @andirs26 It wouldn't boot to Android because our boot.img that got flashed to your phone does some very specific things while booting Ubuntu Touch. However, it's likely that an Android system is still on /system if you haven't wiped it.



  • Then it is probably there - I only used ubports-flasher in the end. Maybe I am getting a little off topic here - but why are there so many mmcblk0p partitions from mmcblk0p1 to mmcblk0p29? Most of them are pretty small (used lsblk in terminal to get the list)..Also there seems to be separate 4M disk called mmcblk0rpmb--



  • Hello, I am trying to do exactly the same thing: installing Ubuntu Touch on a Nexus 5 32GB. But I think the Installer really got stuck. It says "Installing. Installing Ubuntu Touch on your device", and further down: "Waiting for device to enter recovery mode... Flashing recovery and boot images". On the phone I see the recovery screen (with the options mentioned by Andirs26). I did nothing but now I have been waiting for over 30 minutes and nothing has happened so far...
    What could I do?



  • @beegee Hi not sure if you install from windows or Linux but you should probably give admen rights to the tools you use purports-installer or fastboot). Remember to oem unlock the phone - see what tupp posted to thins thread. If the phone is unlocked you should see lock pictured under Google logo at boot. If the above is solved then IIRC you should get the phone to fast boot screen and run ubports-installer with admen rights. Choose the correct device if it is not auto selected



  • @beegee...and click to start the process. The installer should start the recovery mode and do everything automatically.



  • Thank you for your answer!! Meanwhile I tried another way (the magic device tool) and it worked just fine. Still don't know why the installer didn't work though..
    But thank you anyway!



  • @beegee
    No problem, glad that it worked for you also in the end. By the way ubports community recently uploaded video on its official youtube channel where can be seen how it is supposed to be done:

    https://www.youtube.com/watch?v=zuLFTGkuD68


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.