Nexus 10 installation problems

  • Hi,
    I'm new to this forum and I'm seeking advice.
    Since a week I'm trying to install and boot Ubuntu Touch on my Nexus 10 (manta). The only method that worked for me was:
    $ ubuntu-device-flash touch --channel=ubuntu-touch/devel/ubuntu --bootstrap
    from the
    It's very old version and many things are not working. There is no possibility to update it to the latest version of UT.
    I've tried all the versions from ubports with no success. Always tthe same scenario - after pushing files in recovery and rebooting to flash, crossed chip appears after 2-3 seconds and that's it.
    I have also tried to build manually current version by myself, using Ubuntu on my desktop and the official tutorial taken from Ubuntu. All went smooth, i've flashed newly compiled boot and recovery images, rebooted to recovery (with nice ubuntu background this time) and stuck on rootstock-touch-install. After long wait and reboot, my Nexus 10 is ib bootloop with Android logo only.
    Maybe I'm a noob in linux world but if anyone could be so kind to advice me on the right steps it would be nice. Is there no hope for running more recent Ubuntu Touch than the 2nd version from official server?

  • Try to wipe storage. I do it on my oneplus one

  • Hi Trojan_t, did you get Ubuntu touch installed and running yet? I tried a while ago and am still interested.

  • @Yougo Hi, no success still. I'm running out of options, tried many Times and many ways building from scratch from different sources.
    It's bootlooping after flashing or rebooting during uploading files in recovery mode.

  • Reboots during flash can indicate the necessary partitions aren't being mounted. Prior to install you can " df" in an adb shell to view whats mounted, if nothing "mount -a" or mount partitions individually "mount /data" etc. Make sure everything is mounted before install.

    If you install successfully you can go back into recovery after bootloop and check if /data is populated with system.img, system-data, user-data, android-data.

  • Did anyone ever get this to work. I am very interested in this, but havent been able to get it to work. My results were the same as original poster. Install seemed to go fine but after a few seconds the chip with a red line through appears.

  • Hi!

    I tried install ubports image.
    After install cracked, I get follow message in recovery log:
    Invalid signature: /cache/recovery/image-master.tar.xz
    E:Ubuntu update failed

  • Hello again and sorry for my long absence to the forum. I've had a hdd crash and my linux os (secondary on the laptop) disappeared, so I was unable to read any messages.
    I didn't figured out any new steps to make Ubuntu Touch working on my Nexus 10. It looks like there is some part missing in all the tutorials . I will reanimate my Ubuntu biulding environment to come back to the topic and will share my progress.

Log in to reply

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.