Using Ubuntu Touch behind a Proxy



  • Hi!

    I was using my old Aquaris E5 HD Ubuntu Edition Phone with a OpenVPN/Proxy-Server Set Up (same for my Aquaris M10 FHD Ubuntu Edition Tablet - all working well).

    Since two days, I own now a FairPhone 2 on which I have installed Ubuntu Touch as well (latest version installed with cpt).

    I have now some troubles setting up a system wide proxy. I have set up my proxy in a file /etc/profile.d/proxy.sh like:
    export http_proxy=http://<proxy-server>:<proxy-port>
    export https_proxy=http://<proxy-server>:<proxy-port>
    export ftp_proxy=http://<proxy-server>:<proxy-port>
    (I copied the file from my old phone for that - and tripple checked with my tablet) and also tried /etc/environment.
    ftp_proxy=http://<proxy-server>:<proxy-port>
    http_proxy=http://<proxy-server>:<proxy-port>
    https_proxy=http://<proxy-server>:<proxy-port>
    I can see the Proxy-Settings when issuing the "env" command - and wget also uses these Proxy-Settings. I can also see on the proxy log that some background process of Ubuntu Touch are using the settings. But the default browser of Ubuntu Touch does not use them (in ufw.log I can see that the connection is NOT done against the Proxy but the Web Site I try to open directly).

    I also tried to set the proxy with (as this was often suggested for Ubuntu Desktop)
    gsettings set org.gnome.system.proxy mode "manual"
    gsettings set org.gnome.system.proxy.http host <proxy-server>
    gsettings set org.gnome.system.proxy.http port <proxy-port>
    ...

    But all without success.

    Can anyone tell me what I'm missing in order to browse in the internet via a Proxy Server with Ubuntu Touch (Fairphone)? Is the latest browser shipped with Ubuntu Touch not supporting Proxy?

    Thanks
    Stefan


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.