How to mount the device?

  • I have a Nexus 5 with OTA3 installed connected via USB cable to my Antix 15 PC.

    I can see the phone when I lsusb, but I can't see the partition.

    How do I mount the Nexus 5 on my PC?

  • I just tested how to connect to your smartphone (under W10), only "home" directories :

    1. Go to settings
    2. In the "About" menu, choose "Developer Mode"
    3. "Lock security" menu, choose a security mode
    4. Return to "Developer Mode" and enable "Developer Mode"

    I had to remove the USB and put it back in order to consult all "home" directories of the smartphone.
    Directories: "Documents", "Downloads", "Music", "Pictures" and "Videos"

    It would be nice if there is simply an access authorization confirmation request like Android or Windows Phone.

    Attention, the selected security mode will be active for all the smartphone, so if you chose a password, it will be asked for each action on the smartphone, which is quite unpleasant for everyday use and no security has been activated normally.

    EDIT: It's also active to connect into "sudo su" in your smartphone terminal

    This is a translation via Google traanslate

  • @dda

    Thanks. I put the phone into developer mode, but my Antix PC doesn't see the phone partitions.

    Are you saying that your Windows machine only accessed the phone's "home" partition? ... and that you had to disconnect and connect the USB cable each time you switched directories?

    Yes. It would be nice if one could merely mount the Ubuntu Touch phone and access all partitions. I can only access my UT phone using the adb command and adb shell, which is slightly inconvenient when one cannot remember paths.

    I know what you mean about the "lock security" mode continually asking for the passcode. It can be a nuisance. Furthermore, on my phone, the security lock lingered for a short while after I disabled it, but only when I opened a terminal on the phone. I merely turned the phone off (not a full "power down") and turned it back on, and the problem seemed to correct itself.

    In regards to "sudo su," in the phone's terminal, it seems to work without a pass code when security lock is disabled. However, using the adb shell or external mounting of course requires developer-mode/security-lock, so one uses the security lock passcode as the "sudo su" password in those instances.

    I would like to use "su" to become actual root, but what is the root password? I tried unsuccessfully use "sudo passwd" to change the root password within the terminal and also in the adb shell.

  • By the way, for newbies like me working in the adb shell, the "stty" command can resize your adb terminal so that you don't get the weird line feeds and garbled characters.

    I use the command "stty rows 60 cols 160" in my adb terminal.

  • Normally data partition is mounted via MTP if

    • You set a lock code
    • You unlock the screen with the lock code

    You do not need developer mode for this to work.


  • @Flohack
    I tried it with go-mtpfs, and I couldn't make it work unless I was root.

    Not sure which is better: adb or go-mtps?


Log in to reply