Unable to flash 16.04/devel to Pro 5 Ubuntu Edition



  • I am trying to go from UBPorts 15.04 to 16.04 on my Pro 5 (Ubuntu Edition). I have tried the UBPorts installer as well as command line as follows, but it seems my Pro 5 won't enter recovery.

    ~$ sudo ubuntu-device-flash --server=http://system-image.ubports.com touch --device=turbo --channel=ubports-touch/16.04/devel --bootstrap --wipe --verbose [sudo] password for tomas: 2018/01/09 08:58:26 Device is |turbo| 2018/01/09 08:58:26 Flashing version 11 from ubports-touch/16.04/devel channel and server http://system-image.ubports.com to device turbo 2018/01/09 08:58:37 Waiting for device to enter recovery mode ... Failed to enter Recovery

    When I do [Power] + [vol up] it gives me a purple screen with the Ubuntu logo in the middle. Neither UBPorts installer nor command line boots past the splash screen.
    I have tested with different cables and different PCs too. Is there anything else I can try?



  • I recommend that you start the installer from a terminal window and this way you will see some messages telling you if there is a progress of a download or anything else.

    Another of my experiences with the installer is that first the phone has to be booted with power + volume down and then it will say on the installer to boot the phone again with power + volume up. Sometimes it doesn't even say that but I had to try it and it worked.

    Today I tried again to flash xenial (16.04) using the installer and got stuck pushing at 42% and then I canceled everything. I think I will wait until the fingerprint will work (https://github.com/ubports/ubuntu-touch/issues/396).



  • Success!
    Thanks for the tip. I started the installer with sudo ubports-installerand it worked!



  • Wow! Great! What did you do in order to make it work? Just that command and then it worked? And what buttons did you have to press on the phone?



  • Bad news. After OTA update (I think r15) the phone no longer boots. I reflashed it today, but the problem persists.

    How to flash:

    1. Put the phone in fastboot mode by pressing [Power] + [Vol down]
    2. Connect it to your PC with a USB cable
    3. Open a terminal window and launch UBPorts installer with the command sudo ubports-installer
    4. Wait for the installer to download files and ask you to boot the phone to recovery
    5. Boot the phone to recovery by pressing [Power] + [Vol up] (a dark purple screen with Ubuntu logo should appear
    6. Wait for installer to finish
    7. Exit installer


  • I hope they fix it soon... I see there is no new version for today (http://system-image.ubports.com/ubports-touch/16.04/devel/turbo/).

    I think I will wait until fingerprint will function (https://github.com/ubports/ubuntu-touch/issues/396) and then switch to xenial.

    Thank you for writing down the instructions, very useful...



  • What you can do is :
    sudo ubuntu-device-flash --server=http://system-image.ubports.com touch --device=turbo --channel=ubports-touch/16.04/devel --revision=14

    I have done this and installed without any proble;n 16.04 ...


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.