[SLOVED]oneplus one battery level 50%



  • Hello Everybody,

    I'm a new ubuntu touch user, and I've noticed a problem with the battery in my oneplus one,

    First, the battery level shows 50% for a long time, after which the battery suddenly bursts out

    Secondly, often after connecting the phone to charging, UT does not show that the phone is charging, so I do not know if anything is happening because the battery level is all the time 50%;)
    0_1521151817919_screenshot20180315_161036754.png
    Any suggestions for solving this problem?



  • @mar hi, welcome. There are a lot of problems with how UT reports battery levels, and how quickly the battery drains, but we're seeing some improvements lately.

    See https://github.com/ubports/ubuntu-touch/issues/299

    About your second point, are you sure the cable and connector are in good condition? For example I have to be extra-careful when connecting my Nexus5 because its plug is special.



  • Thanks for the quick answer @advocatux.
    My battery is not running out too fast, the problem lies in the fact that UT does not show current battery level, and I do not know if the phone is charging when connected to a laptop. The cable is rather fine, because when I turn off the phone and connect to the charging cable the phone shows that it is charging, but when it is turned on it does not show. In the link you provided to me, I did not find any solution :(, unless you suggest that I install the Devel version of the UT.

    I just forgot to add that I have 15.04 stable UT, I did not manage to notice whether this problem occurred from the moment of installing UT, or after some of my interference in the UT. My only intervention in the system was after useing the tutorial contained in this link https://forums.ubports.com/topic/1015/howto-opo-fix-mtp-driver-permissions, which on the occasion helped me to solve my problem ( Thanks to @Flohack).

    p.s.
    sorry for my bad english xD

    p.s. 2
    I made this screen shoot this morning, and when UT was switch off, phone shows on the screen the battery is charged in 100%, but UT still showing 50%

    0_1521271950040_screenshot20180317_072705972.png

    Little update:
    I also noticed that UT constantly monitors the battery level, because over time it reduces the brightness of the screen. The question is why GUI stopped at 50% and does not want to update itself, since UT itself knows what is the current level of battery.

    After reboot system is working Ok, i don't know what caused the problem.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.