Updating apps to 16.04

  • @doniks No, my click package passed the click-review from the outset.
    I am saying that removing the c++ code caused the message to go away when uploading it to the open store.
    It seems that even when your click package passes the click-review, you still need to have it reviewed by someone from the openstore, before getting it submitted.

  • Is it possible to declare both frameworks for 15.04 and 16.04 together in one manifest.json so that the click package can be installed on both Ubuntu Touch versions?
    The App itself is pure HTML5+JS so nothing needs to be compiled.

    The current version looks like this:
    "name": "sakawochi.wendigosoft",
    "description": "The micro aquarium that fits into your pocket",
    "architecture": "all",
    "title": "Sakawochi",
    "hooks": {
    "sakawochi": {
    "apparmor": "sakawochi.apparmor",
    "desktop": "sakawochi.desktop"
    "version": "0.2.11",
    "maintainer": "Me <me@mymailbox.org>",
    "framework" : "ubuntu-sdk-15.04.6"
    Could I just add a "," or ";" in the framework field?

  • @wendigo No, you cannot do that. If the app works on both versions, and you want to keep uploading for both versions, I would suggest using the last 15.04 framework and apparmor 1.3 policy version, and just uploading the same package for both xenial and vivid.

    However, rather than that, I'd suggest only uploading new versions for xenial. As I understand, the plan is to stop taking new app uploads for vivid soon, perhaps when OTA-5 is released.

  • Thanks, I'll stay with framework 15.04 then and offer it for both versions on OpenStore.
    Since not everyone will update to OTA-4 I want to support the old version until OTA-5 is out.

  • @danchapman Thanks for the tip. I removed the .py files and I was using this one import in last version:

    import io.thp.pyotherside 1.4

    Everything was working, but in the last update of Ubuntu Touch (2018-W40), the python side is not working.

    alt text

    In the last UT version I have the package libpython3.5:armhf, then I think the error is coming because the libpython3.4 doesn't exist. But... I'm just importing "io.thp.pyotherside 1.4", the crash (IMO) is coming from the pyotherside from the system (?).

    I tried import io.thp.pyotherside 1.5, but same result.

    Any help please? Thanks in advance!

Log in to reply