Xenial rc fails to boot on Meizu MX4



  • @advocatux Only mentioned it in case it might be causing an issue for @ThePossessor in combination with 16.04. Really have no idea. Can only suggest he tries clean wipe install 15.04 then the same on 16.04 and see how it goes.



  • Thanks @advocatux and @Lakotaubp for your answers and tests.

    @Lakotaubp Switching back to 15.04 works perfectly each time. I have tried to go from there to 16.04 with wipe many times. The first boot then works ok. After basic setup I do poweroff.
    When I switch on again:

    • I get the meizu logo powered by ubuntu
    • Am small black bar with a text appears on bottom
    • button light goes on
    • button light goes off
    • small black bar disappears
    • screen goes totally bright
    • If this is the first time to switch on, then after ~20-40 seconds the device boots one more time. After this, the boot progress simply stops here at every boot.

    I even tried a second MX4 I have access to. It gave the exact same result.



  • @thepossessor I must admit mine as I said does take a time to start up like yours, but after the bright Miezu screen so far always has.
    When the screen appears to hang have you tried pressing the power button down again to see if that will force it to boot up . I've done that once before.
    Also I'll check the spec/ build numbers of my Mx 4 tomorrow and let you know so you can check against yours see if there's a difference. It might give us a clue to something.



  • @lakotaubp pressing the button again does not have any effect.

    Holding it a few seconds switches off again as expected.



  • @thepossessor and if you keep holding after it switches off does the reboot still hang. Mine reboots as normal if I do this after the long bright miezu screen hang.
    One last thing try the dev version of 16.04. Not sure if you have, it might just have a different effect.



  • @thepossessor Have put mine on the dev channel and restarted and all went well. The model number for mine is M461



  • Holding power button makes the phone power off and then power on again. It does not boot to UI though.

    I am already testing dev channel too. No difference.



  • Model is "M461 LTE Mobile phone".

    Develop channel makes no difference on mine.



  • @thepossessor then I'm stumped sorry different model may well be the issue. I would now post a bug report if you havn't already. If I come up with anything else I will get back to you. Lets hope someone else can shed light on this.
    Have you tried the welcome and install group just in case
    https://t.me/WelcomePlus



  • Sorry I had a typo. It is a M461 too of course.

    The forum search did not return anything really valuable.

    It is files as bug . I guess I just have to sit and wait.



  • I made some further tests by rebooting at different points of basic setup process.
    This way I found out that booting is not working anymore after timezone setup.
    I then first removed timezone settings with adb shell in the first boot. After this I was able to reboot successfully multiple times.
    I then configured a different timezone. After this I could still reboot fine.
    To crosscheck I configured the timezone I usually choose. The problem was back,

    "Europe/Berlin" works but "Europe/Luxembourg" does not.

    Just weird.



  • @thepossessor I wonder if this is linked to calendar and clock crashing? Both crash after putting in settings or account settings. They don't stop the thing booting up though.
    Glad you can boot up now are you still on dev. The updates may fix the problem as they roll out.



  • @lakotaubp yes I am still on devel channel.

    As for the crashing of clock app. It is like most apps on MX4. If they crash when they ask for additional permission then:

    • Just uninstall it.
    • Reboot phone.
    • Reinstall it.
    • Setting additional permission then usually works.

    This behaviour was reported long long time ago. I have no clue why this still is so.

    Well actually I am not sure if this is what you meant with clock crashing.



  • @thepossessor it s affecting bq5 as well not tried nexus 5 yet as need working calendar for work. Uninstalling does nothing have tried after each update on dev channel.



  • @lakotaubp - it does usually help with crashes that happen when the apps prompt for access to additional privileges. It must be a bug with the app itself in your case. I am not using the calendar much so no ideas on the one. The app starts - this much I can say. ,-)



  • @thepossessor Hi again just wondering if your startup timezone issue has cleared up now we've had more updates.



  • @lakotaubp Hi, actually I didn't do any new tests because the issue I opened on their bugtracker does not show any progress. They even still consider it unconfirmed. Issue 696
    So I guess a new test is not worth the effort. Or else nobody cares to update bugtracker?



  • @thepossessor Hi have just read the GitHub bug tracker all the unconfirmed means is that no-one else has so far reported the same issue. All of which makes your glich very odd. There has to be more than three mx4s out there. I certainly have not been able to reproduce the issue. If you do try again before 16.04 stable rolls out please let me know how it goes.

    P.S the easiest way to see/report logs is probably the Logviewer app in the Openstore



  • @lakotaubp Hi again. After doing all available updates, on my working phone I have set the timezone to Luxembourg. Then I tried several reboots. In order of appearance: 1x Fail, 2x Success, 7x Fail . I then had to do a wipe install . Still it hangs on reboot as soon as I pick the timezone I normally need.

    Btw. a logviewer app is only useful if the phone still starts up.

    But please let me to see if I got you right. You are able to set timezone to Luxembourg and have several successful boots after this? If this is true, I need your phone - lol



  • @thepossessor I am very unhappy to report that having a Luxembourg time zone stuffs up your mx4.
    Just tried it and no boot up past Meizu bright white screen. if anyone wants to try that time zone on another model fell free and post back here. Will update bug report if not today tomorrow, possibly after reflashing my mx4.: (


Log in to reply