Oneplus one Xenial (16.04) - constant loss of connection

  • Dear all,
    I recently installed UBports 16.04 on a second hand Oneplus one I bought for this purpose.
    I am suffering from constant loss of connection... I can load one web page and then I get "network error".
    There is an open bug on github which I am following, but I am surprised this doesn't seem to be an issue for most users...
    I have tried a few things with no joy so far:

    • flight mode on then off (problem reappears after 1 web page)
    • moving from channel rc to dev with latest updates
    • changing wireless regulatory domain with "iw reg set" (I live in UK) in the terminal

    Even more baffling, I thought it was a wifi-only problem, but if I disable wifi it doesn't work via mobile network either. The device is pretty much unusable, but I am ready to fight if anyone has a clue?
    Thanks, Marc

  • @truscellino Is this with browser or browser next?. I have a OPOdev on 16.04 dev and have not had any connection issues at all with browser. I have not yet tried browser next enough to comment on that but there are issues with it.

  • Hi,
    Thank you for replying.
    I am using Browser Next, but when connection is lost, nothing works: open-store, web apps, system updates... so it's clearly not a browser problem, but it is relating to networking. I haven't done any tweaks to the system so I am a bit puzzled...

  • @truscellino Can you try browser, just to rule out that as the problem. If the same happens with browser then we're not looking for a more general issue.You never know browser next crashing could be pulling the rest with it. I have not heard (yet) of connection issue on OPO as a stand alone issue.

  • OK thank you for suggestion! I tried with Browser and got same problems :-(.
    However, today I connected to the guest wifi in the office and everything worked fine. This is a building where only one wifi network is visible, whereas at home there is always a list of wifi networks from the neighbours etc.
    So it's definitely a wifi problem, but dependent on specific wifi parameters like available connections, channels etc.
    I think I will struggle to get to the bottom of it but I'm not giving up...

  • @truscellino I used to get something similar with the wifi hotspot network BTwifi with Fon. That kept interrupting on my phone as I had used it once while away, so it kept trying the same at home as well.
    Sounds like you are getting similar with all those networks near by but why I don't know.
    How many of them are "open" networks just looking for a device to connect to. Though why they get through your home network again no idea. Please let us know when you solve it.

  • Picking up on and adding to what @lakotaubp said:
    Could you go to the wifi settings then tap on 'Previous networks' and delete everything there except the AP you want to connect to at home? I'd be interested to know if that makes any difference at all for your situation.

Log in to reply