Development testers for Anbox

  • That's a really great news! Many thanks @mariogrip

  • Nice work indeed @mariogrip - wonderful to see Anbox development continues!

    I just tested on a Meizu Pro 5 (running 16.04/devel, Version 162) and when the phone is fastboot rebooted after the anbox-kernel flash, neither of the SIMs is detected.

    I simply fastboot flashed the previous boot.img back - and my dual SIMs are detected once more, no apparent harm done :-)

    So, it seems that Anbox is not quite ready for those users requiring a Meizu Pro 5 that still also makes and receives phone calls...

  • @brywilson Seems like the Turbo-boot.img has not ben updated yet as the version available is from 6/1/2018.

  • Just followed the procedure on my OPO and it has gone flawlessly! Apps don't launch always, thought. I once opened the settings app successfully, but now every app crashes right after lauching.

  • FP2

    The pre-installed apps seem to load all right, except for WebView Shell, which I don't think is even an app.

    After some continued use, they all seem to crash on open. Functionality seems to come back sometimes.

    I was able to install other apps. BUT, no on-screen keyboard :P

    NOTE: Updating Ubuntu Touch will kill anbox completely, and you have to re-flash the anbox kernel again.

  • I tested with nexus 5 and had similar results as the others. I was able to open the stock apps, including settings. One thing to note is that it has no internet device, so it was not possible to connect to the internet from withing the container. I was able to install and open whatsapp. But couldn't do much more than that without keyboard or internet.

    I also installed FDroid, but again, no internet. I tryed to install aosp stock keyboard, but after that, I wasn't able to open any app. To be more precise, anbox doesn't initiate anymore for some reason. I'll try to reinstall and see if I can reproduce this problem to be sure it was the keyboard app that caused anbox to not initiate anymore.

    That is it for now: all stock apps open, no internet, no keyboard. Kinda of slow too. Most important, flashing the modified boot didn't brick my phone :P (it happened once with another phone).

  • @mariogrip Come on Marius, throw us a bone! Update the Anbox image for Pro 5. You said long time ago, that you have a anbox that works with Mobile network and while you uploaded the anbox images for other devices, you did not update the one for Pro 5. So we can't test it as there us nothing new to test.
    Thank you.

  • Administrators

  • Administrators

    I have now updated the image with an version that has working network! You can update this using anbox-tool upgrade

  • @mariogrip I love you Marius ❤

  • 0_1537106762511_screenshot20180915_134658923.png

    Sometimes I get this on FP2 when opening an app, and then it doesn't work. What does it mean exactly?

    A few cases where this happened:

    1. Updated UT from settings (assumed that it overwrites kernel), so reflash of anbox kernel fixed it.
    2. Updated Anbox , but then a reboot fixed it.

  • Administrators

    This happens when the backend container session daemon is not running, so this is anbox trying to start a container session as user but failing, there is no "error" messages so it just get stuck (or crashes) here. So what we want here is to display an error message instead of this, but not implemented yet.

  • Administrators

    Got android keyboard working! it's not great nor native, but better then nothing.


    This was fixed by adding hack to allow android keyboard, this is temporarily solution. Added bug report to add support for native keyboard here:

    Upgrade using:
    note, Using apt install here, that way we upgrade just anbox and nothing else

    sudo mount -o rw,remount /
    sudo apt update
    sudo apt install anbox anbox-common anbox-ubuntu-touch
    anbox-tool upgrade

  • Yay. It works.

    How do you use anbox-tool for install?

    I tried
    anbox-tool app-install FDroid.apk
    But it said that anbox is not running.

    anbox-tool status confirmed that it was not running. But the installed apps do run.

  • This post is deleted!

  • @mariogrip You're the MAN!!!

  • @stefano Does it work now on Pro 5?

  • usually when I anbox is not starting, I just restart the ubuntu. It works most of the time. Is there a better way to make anbox run again? Also, for those not doing this, if you are connected to anbox through adb shell and lxc-console you can see debugging msgs of anbox in realtime on your PC. This helps a lot to understand what anbox is doing, since it includes error msgs.

    "does is work in 'other phones'?"

    The only thing specific to each phone, I belive is the modification in the "boot image" to include the requeried kernel modules (for ashmen and binder nodes in /dev). Modifications in the anbox.img are the same for everyone, I believe.

    Hey mario, if you are going to confirm this, are there other modifications to the kernel or the boot img that you do?

  • @mihael Yes it do work on a Pro 5...

  • @mihael Haven't tried that yet as I'm on holiday and have not access to a PC to flash it.

Log in to reply