Development testers for Anbox

  • @ursfan Yes.

  • Hi, has anyone tried to install anbox on a bq M10 HD yet?

    i have , but anbox-tool is telling me i need to flash the kernel, but i did that?!

    i followed instructions from here:

    might there be some step missing? or is the anbox-boot-cooler.img not functional?

  • @yougo: Just stating the obvious, but it is a mistake that I made initially when trying anbox on my M10FHD: Did you use the correct name for the boot partition when flashing the boot image (boot instead of bootimg)?

  • Exciting progress. I sucessfully installed Anbox on my FP2. For installing additional apks; I tried to install adb android-tools-adb:

    phablet@ubuntu-phablet:~$ sudo apt install android-tools-adb
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 108 not upgraded.
    Need to get 64.1 kB of archives.
    After this operation, 152 kB of additional disk space will be used.
    E: You don't have enough free space in /var/cache/apt/archives/.

    This is confusing, because the system info says, that there is more than 23 GB free space on my FP2.

    Some idea to resolve this issue?

  • Using pawlinskis approach from

    sudo mount -o rw,remount /
    sudo rm -r /var/cache/apt
    sudo tune2fs -m 0 /dev/loop0
    sudo apt update
    sudo apt install android-tools-adb
    sudo mount -o ro,remount /

    The system image has just 2 GB and the commands above free some of that space. The 23 GB free storage you mentioned is the part of the storage reserved for user data.

  • @honigwald I have the same problem. BQ Aquaris FHD (frieza).
    Flashed the the kernel as shown at, but anbox-tool status says:

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO

    Prior to installing I grew the ubuntu.img / system.img to have enough space for apt on /.
    Somehow the kernel does not get installed... Anyone has solved this?

    Maybe this is relevant: I bought the Android version of the tablet - then installed UBports UT. Maybe this changes the boot partition / image?

  • @arubislander So did I. Maybe boot is incorrect?

  • I just used ubports-installer to flash 16.04/rc onto the frieza, then resized the partition, then installed anbox using the tutorial. No success 😞
    @mariogrip How did you do it?

  • Hi,
    I've tried it on BQ m10 FHD and it does not seem to work.
    I've flashed the Kernel and installed anbox-tool but i can't install it, because it says the Kernel isn't installed.

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!
    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO

    I tried reflashing it a couple of times, without success.

  • Can someone point me to the used kernel source for bacon anbox. The one in github seams not to have the "anbox" changes.

  • Maybe this is useful feedback 😉

    These are the apps that work for me with anbox on Fairphone 2

    • CatLog
    • Onleihe
    • Spotify
    • Threema (Polling instead of Push notifications)
    • WhatsApp (probably also polling)
    • my banking app

    But please take note: I haven't tested those in depth and am not using them on my daily driver, so maybe some problems went unnoticed so far.

    What didn't work

    • AdAway (needs root)
    • Bücherhallen (doesn't run without gapps; managing wish list works)
    • car2go (doesn't run without gapps)
    • DB Navigator (crashes immediately on start)
    • Drive Now (doesn't run without gapps)
    • Firefox (looks as if it works, but web pages are rendered entirely black)
    • iButtons (simply doesn't start)
    • Real Drum (simply doesn't start)
    • Stadtrad (doesn't run without gapps)
    • vlc (upper third of screen remains black, the app window seems shifted down and lower part is not visible)

  • @ingo also Telegram works

  • @ingo Thanks for your recommendation. The installation did work, but then a system update of UBports has detroyed my Fairphone. No, problem, it is a developer device. I was able to recover my Fairphone and install Anbox abein with the android tools as described on the documentation page:

    I could mange to install FDroid from a download and then Yalp Store within FDroid. Running Yalp Store seems to be to abitious. Yalp Store crashes while logging into the Play Store. So, in general Anbox is working on my Fairphone.

    Sometimes the interaction with Android apps is liettle bit tricky because of the missing back navigation button on the system level. Alien Davlik adds a navigation bar with a back button. Maybe this could be an approach for Anbox either. The disadvantage would be a smaller screen.

  • I payed around with Google apps to check the system integration. It seems, that Anbox is completely isolated.

    Does someone know, where I can find the storage for Anbox? I try to import an adressbook export in the related Android App.

  • @pawlinski try to use test image (anbox-boot-$CODENAME-test.img)

  • Hiya i just wanted to leave a link here. I accidentally started another thread. If you read into this link you'll find the instructions on how i installed Anbox on an OPO. So far successful. I just need some time to 'play' with it now to see where it is at and what can be done with it:

  • @marc_aurel Storage is in ~/anbox-data/data/media/0/

  • @bodow Thanks for the clear advice. Unfortunately I'm struggling with accessing the storage for Anbox.

    I tried to copy my address-book to the Anbox container:

    adb push contacts.vcf /home/phablet/anbox-data/data/media/0/
    adb: error: failed to copy 'contacts.vcf' to '/home/phablet/anbox-data/data/media/0/': remote Permission denied
    contacts.vcf: 0 files pushed. 142.5 MB/s (720808 bytes in 0.005s)

    I also can't access the media directory. I only can list the content of the data directory, but I can't switch to a subordinated directory.

    phablet@ubuntu-phablet:~/anbox-data/data$ sudo ls -l
    [sudo] password for phablet: 
    total 5136
    drwx------  2 root   root             4096 Dec 13 18:20 adb
    drwxrwxr-x  2 system system           4096 Dec 13 18:20 anr
    drwxrwx---  4   1023          1023    4096 Dec 13 18:20 media
    phablet@ubuntu-phablet:~/anbox-data/data$ cd media
    bash: cd: media: Permission denied
    phablet@ubuntu-phablet:~/anbox-data/data$ sudo cd media
    sudo: cd: command not found

    I have a similar problem if I use the file manage on the device. But I also tried an adb push command within the device without success.

    phablet@ubuntu-phablet:~/Downloads$ adb push contacts.vcf /data/sdcard/Download
    failed to copy 'contacts.vcf' to '/data/sdcard/Download': secure_mkdirs failed: Permission denied

    Some idea?

  • @marc_aurel just my 2 cents here. Did you try, before to navigate into the anbox folder, to type sudo su and gaining the root access?
    Second hint: you could try to move first your contacts file to an accessible folder, as for example Documents or Downloads, with adb push from your PC and then, from the terminal on your PC, you could type phablet-shell instead of adb shell, since I found out the latter has some limitations in writing on the phone partition. In the end, you could just copy your file, maybe better with root privilege, to /home/phablet/anbox-data/data/media/0/ using the cp or mv command.

  • Someone suggested the following somewhere

    mkdir -p /home/phablet/AnboxHome
    sudo chmod -R 777 /home/phablet/anbox-data/data/media/0
    sudo mount --bind /home/phablet/anbox-data/data/media/0 /home/phablet/AnboxHome

    But with the clear hint that making things 777 generally is not a good idea.
    Of course the minimal way would be just the second line. The other are just there to have an easier/shorter path.

Log in to reply