Development testers for Anbox



  • Hi, has anyone tried to install anbox on a bq M10 HD yet?

    i have , but anbox-tool is telling me i need to flash the kernel, but i did that?!

    i followed instructions from here: https://docs.ubports.com/en/latest/userguide/dailyuse/anbox.html

    might there be some step missing? or is the anbox-boot-cooler.img not functional?



  • @yougo: Just stating the obvious, but it is a mistake that I made initially when trying anbox on my M10FHD: Did you use the correct name for the boot partition when flashing the boot image (boot instead of bootimg)?



  • Exciting progress. I sucessfully installed Anbox on my FP2. For installing additional apks; I tried to install adb android-tools-adb:

    phablet@ubuntu-phablet:~$ sudo apt install android-tools-adb
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
        android-tools-adb
    0 upgraded, 1 newly installed, 0 to remove and 108 not upgraded.
    Need to get 64.1 kB of archives.
    After this operation, 152 kB of additional disk space will be used.
    E: You don't have enough free space in /var/cache/apt/archives/.
    

    This is confusing, because the system info says, that there is more than 23 GB free space on my FP2.

    Some idea to resolve this issue?



  • Using pawlinskis approach from https://forums.ubports.com/post/14023

    sudo mount -o rw,remount /
    sudo rm -r /var/cache/apt
    sudo tune2fs -m 0 /dev/loop0
    sudo apt update
    sudo apt install android-tools-adb
    sudo mount -o ro,remount /

    The system image has just 2 GB and the commands above free some of that space. The 23 GB free storage you mentioned is the part of the storage reserved for user data.



  • @honigwald I have the same problem. BQ Aquaris FHD (frieza).
    Flashed the the kernel as shown at docs.ubports.com, but anbox-tool status says:

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO
    

    Prior to installing I grew the ubuntu.img / system.img to have enough space for apt on /.
    Somehow the kernel does not get installed... Anyone has solved this?

    Maybe this is relevant: I bought the Android version of the tablet - then installed UBports UT. Maybe this changes the boot partition / image?



  • @arubislander So did I. Maybe boot is incorrect?



  • I just used ubports-installer to flash 16.04/rc onto the frieza, then resized the partition, then installed anbox using the doc.ubports.com tutorial. No success :(
    @mariogrip How did you do it?



  • Hi,
    I've tried it on BQ m10 FHD and it does not seem to work.
    I've flashed the Kernel and installed anbox-tool but i can't install it, because it says the Kernel isn't installed.

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!
    
    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO
    

    I tried reflashing it a couple of times, without success.



  • Can someone point me to the used kernel source for bacon anbox. The one in github seams not to have the "anbox" changes.



  • Maybe this is useful feedback ;)

    These are the apps that work for me with anbox on Fairphone 2

    • CatLog
    • Onleihe
    • Spotify
    • Threema (Polling instead of Push notifications)
    • WhatsApp (probably also polling)
    • my banking app

    But please take note: I haven't tested those in depth and am not using them on my daily driver, so maybe some problems went unnoticed so far.

    What didn't work

    • AdAway (needs root)
    • B├╝cherhallen (doesn't run without gapps; managing wish list works)
    • car2go (doesn't run without gapps)
    • DB Navigator (crashes immediately on start)
    • Drive Now (doesn't run without gapps)
    • Firefox (looks as if it works, but web pages are rendered entirely black)
    • iButtons (simply doesn't start)
    • Real Drum (simply doesn't start)
    • Stadtrad (doesn't run without gapps)
    • vlc (upper third of screen remains black, the app window seems shifted down and lower part is not visible)


  • @ingo also Telegram works


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.