Development testers for Anbox



  • @mariogrip I love you Marius ❤



  • 0_1537106762511_screenshot20180915_134658923.png

    Sometimes I get this on FP2 when opening an app, and then it doesn't work. What does it mean exactly?

    A few cases where this happened:

    1. Updated UT from settings (assumed that it overwrites kernel), so reflash of anbox kernel fixed it.
    2. Updated Anbox , but then a reboot fixed it.

  • Administrators

    This happens when the backend container session daemon is not running, so this is anbox trying to start a container session as user but failing, there is no "error" messages so it just get stuck (or crashes) here. So what we want here is to display an error message instead of this, but not implemented yet.


  • Administrators

    Got android keyboard working! it's not great nor native, but better then nothing.

    0_1537109249889_screenshot20180916_164621189.png

    This was fixed by adding hack to allow android keyboard, this is temporarily solution. Added bug report to add support for native keyboard here: https://github.com/ubports/anbox/issues/5

    Upgrade using:
    note, Using apt install here, that way we upgrade just anbox and nothing else

    sudo mount -o rw,remount /
    sudo apt update
    sudo apt install anbox anbox-common anbox-ubuntu-touch
    anbox-tool upgrade
    


  • Yay. It works.

    How do you use anbox-tool for install?

    I tried
    anbox-tool app-install FDroid.apk
    But it said that anbox is not running.

    anbox-tool status confirmed that it was not running. But the installed apps do run.



  • This post is deleted!


  • @mariogrip You're the MAN!!!



  • @stefano Does it work now on Pro 5?



  • usually when I anbox is not starting, I just restart the ubuntu. It works most of the time. Is there a better way to make anbox run again? Also, for those not doing this, if you are connected to anbox through adb shell and lxc-console you can see debugging msgs of anbox in realtime on your PC. This helps a lot to understand what anbox is doing, since it includes error msgs.

    "does is work in 'other phones'?"

    The only thing specific to each phone, I belive is the modification in the "boot image" to include the requeried kernel modules (for ashmen and binder nodes in /dev). Modifications in the anbox.img are the same for everyone, I believe.

    Hey mario, if you are going to confirm this, are there other modifications to the kernel or the boot img that you do?



  • @mihael Yes it do work on a Pro 5...



  • @mihael Haven't tried that yet as I'm on holiday and have not access to a PC to flash it.



  • On Telegram advocatux give me a link that worked to install apps, as Marius told me he need to do more work on the anbox-tool...

    https://docs.anbox.io/userguide/install_apps.html

    I have test this and indeed it install the apps.



  • @xray2000 The method I have used to install apps is

    $ sudo mv $APP ~/anbox-data/data
    $ sudo lxc-console -ndefault -P /home/phablet/anbox-data/container -t0
    $ cd data && pm install "app.apk"

    substitute "app.apk" for the name of the apk you are installing and $APP for it's path outside anbox

    EDIT: sorry, I miss typed the sudo command.



  • @alkis said in Development testers for Anbox:

    @xray2000 The method I have used to install apps is

    $ sudo mv $APP ~/anbox-data/data
    $ sduo lxc-console -ndefault -P /home/phablet/anbox-data/container -t0
    $ cd data && pm install "app.apk"

    substitute "app.apk" for the name of the apk you are installing and $APP for it's path outside anbox

    sudo lxc-console -ndefault -P /home/phablet/anbox-data/containers -t0



  • I just tested the new anbox update and yes, both the keyboard and network is working. I even made a whatsapp call to my father, for shits and giggles. It doesn't have sound as expected, but it did connect.


    this is a screenshot of a msg, but I also made a call with no sound.
    If we get the sound server working, we would be able to start making whatsapp calls! That would be awesome.
    Anyway, it is already a great achievement.

    Also, I noticed that sometimes, if you already have a anbox app window opened, anbox won't open another app



  • @alkis This dont work on a Pro 5, it seems the lxc-console is running anbox output on my device continues and i can not give any command there. With the link advocatux give me that works a lot better no need to move any apk or anything...



  • This post is deleted!


  • MEHHH!!!!
    0_1537192699518_70dbbac8-da0d-439e-8663-90d426686a16-image.png



  • I can confirm that the turbo-test img works on the Pro 5. I also installed WhatsApp and it works. I am so very glad and delighted about all this work!!!



  • anyone successfully get frieza working? I tried but am told that

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!
    

    Pretty sure I went through the procedures correctly but maybe I missed something. If I don't hear back from anyone I'll try again in a couple of days and open an issue if it still doesn't work.


Log in to reply