Development testers for Anbox

  • @mihael Haven't tried that yet as I'm on holiday and have not access to a PC to flash it.

  • On Telegram advocatux give me a link that worked to install apps, as Marius told me he need to do more work on the anbox-tool...

    I have test this and indeed it install the apps.

  • @xray2000 The method I have used to install apps is

    $ sudo mv $APP ~/anbox-data/data
    $ sudo lxc-console -ndefault -P /home/phablet/anbox-data/container -t0
    $ cd data && pm install "app.apk"

    substitute "app.apk" for the name of the apk you are installing and $APP for it's path outside anbox

    EDIT: sorry, I miss typed the sudo command.

  • @alkis said in Development testers for Anbox:

    @xray2000 The method I have used to install apps is

    $ sudo mv $APP ~/anbox-data/data
    $ sduo lxc-console -ndefault -P /home/phablet/anbox-data/container -t0
    $ cd data && pm install "app.apk"

    substitute "app.apk" for the name of the apk you are installing and $APP for it's path outside anbox

    sudo lxc-console -ndefault -P /home/phablet/anbox-data/containers -t0

  • I just tested the new anbox update and yes, both the keyboard and network is working. I even made a whatsapp call to my father, for shits and giggles. It doesn't have sound as expected, but it did connect.

    this is a screenshot of a msg, but I also made a call with no sound.
    If we get the sound server working, we would be able to start making whatsapp calls! That would be awesome.
    Anyway, it is already a great achievement.

    Also, I noticed that sometimes, if you already have a anbox app window opened, anbox won't open another app

  • @alkis This dont work on a Pro 5, it seems the lxc-console is running anbox output on my device continues and i can not give any command there. With the link advocatux give me that works a lot better no need to move any apk or anything...

  • This post is deleted!

  • MEHHH!!!!

  • I can confirm that the turbo-test img works on the Pro 5. I also installed WhatsApp and it works. I am so very glad and delighted about all this work!!!

  • anyone successfully get frieza working? I tried but am told that

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!

    Pretty sure I went through the procedures correctly but maybe I missed something. If I don't hear back from anyone I'll try again in a couple of days and open an issue if it still doesn't work.

  • On N5 I recognized: Installing System updates seem to cause the reinstallation of the native kernel. This causes a disfunctionallity of anbox and heating of your device (100% CPU). I recommend to disable automatic System updates.

  • @mariogrip
    you are God?

  • @jor1196 No he created (programmed) god! ^^

  • @mihael Fair play to you on getting Anbox apps to work on the Pro5! Any chance you can reveal how you did it? When I try (on turbo/devel), like a previous poster, I'm getting "Anbox is not running" errors and when I type "anbox-tool status", it reads "Running: No" - but the preinstalled apps open and seem fine.

    Using the "lxc-console" method either tells me that I don't have "sufficient privileges for default" or if I use "sudo" for the command, I get endless debugging verbiage...

  • Administrators

  • @brywilson
    try this method if it still woks

  • @brywilson I only did what is recommended on this page, using the anbox-boot-turbo-test.img. I had previously tried to install anbox and it didn't work (the previous anbox-boot-turbo.img kernel) so an anbox android image was already on my device so anbox-tool install didn't work. I then used anbox-tool upgrade and then everything worked. Regarding logging into the container, yes, I use the sudo way. Yes, there are a lot of debugging messages flooding the screen but in spite of that I type the commands (thanks @Alkis for the code above)and then I hit enter and this is how I got the apk(s) installed.

  • Hi all,
    Somehow my anbox on OPO is still not runing even after few restarts.
    Is there any option to start it via terminal?

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: OK
    System: OK
    Enabled: YES
    Running: NO

  • Thanks muchly to @mariogrip @Stefano and @mihael for your wonderfully quick replies there! I already had the anbox-boot-turbo-test.img installed and ended up trying the advice given by @mihael and using the "sudo lxc-console..." command and then the "cd data && pm install app.apk" commands whilst the debugging was still running...

    And it worked! Although my celebrations were shortlived, after receiving the "App won't run without Google Play services etc etc" and the app then crashing 😕

    Despite knowing that it would be too easy a solution, I just tried installing google-play-services.apk - and now my installed apps crash instantly 😃

  • @tricky In my very poor understanding, somehow the anbox-tool does not reflect the state of the android container. So, the android apps can still work even though anbox-tool status says that is not running. For me, the true way to find if the android container is not running is to try to login into it with sudo lxc-console -ndefault -P /home/phablet/anbox-data/containers -t0 - when it's running I can login and when it's not then it says so. Why would I need that? - because if an android app does not start then I need to find if it's because of the android container not running, in which case I don't know how to start it except by a reboot of the phone 😞

    Maybe @mariogrip could help us with the command to start the android container? 🙂

Log in to reply