Are we forgetting the little bugs?



  • @dobey It is not a button issue as I use the screen to close it, so that makes me think it is software. True it could be a hdd issue though, but the rest of the phone is fine.



  • @edc I have cut down most of the software on my phone to ensure that this was not the case, but in saying that, I may of missed something.



  • @flohack I have, on my OPO, double boot on startup too



  • @rocky58 thanks for commenting on this and confirming that you have the double boot and close down on your OPO. At least now I know that it is not just mine and that there is no hardware issue my side.

    I had this happen again last night when I closed it down. The phone rebooted after closing it down via the System > Shut Down option.



  • Hi all,
    Valuable discussion, I think. I would concur with the comments above.
    I also have OPO (16.04 dev channel) with occasional double boot. In my experience, the main issue by far is constant wifi drop-outs that make the phone unusable at home. But most people don't experience that problem so it won't be fixed.
    Both these bugs are clearly not systematic and hard to reproduce, so we (user impacted) have to run investigations and provide more clues.
    I don't think any of us is expecting miracles from a team with little resources. What I would hope is that people in the community would give me some guidance to investigate the bugs I am experiencing. This is where users (like me) that are not real devs, still can help improve the product...



  • @truscellino This is exactly how we who are not devs can all help as you said. By helping each other trying to solve things and maybe helping point the people with the knowhow in the right direction on these annoying problems.
    I still haven't had a double boot on the OPO so can't help there. As for wifi the only time I've had an issue was at the local hospital which has different wifi all over the place. Their free wifi keeps dropping out every time you move as what I guess are numerous signals of equal or stronger strength kick in. At home no issue with 5 signals show, hospital had over 12 at one time and had issues. Guess you've tried renaming your two channels to make them stand out from the wifi noise.



  • One thing that I did think of yesterday with the double boot when closing, could it be my big fingers and the lines between the power off and restart being close together. So actually when I think I am clicking power off my finger is accentually clicking restart without me knowing?

    So if this is the case would the power off and restart buttons be better slightly further apart? May be a very quick fix for what could be a user error....

    This does not explain the double boot on start up though.



  • @ukphil To clear that bit up when switching off just press and hold the power button till the screen goes black. Theres no buzz by the way when switching off.



  • @lakotaubp held the power button down for a bit of time, the phone rebooted and then did a double boot up.



  • @ukphil When double booting what screen order do you get? I get on start up hold power button till buzz. Then One plus screen followed by UbuntubToch screen, then ubuntubtouch screen with five dots (goes through dots twice) then boots through to sim pin screen and thats it. When yours double boots does it go right back to the One plus screen. I don't have an answer just curious to know whats happening.
    When powering off with the power button then yours reboots on its own if you release the power button as soon as th screen goes blank after the switch off, reboot, cancel screen.Again just so I can understand what is happening as,I cannot reproduce this.



  • @Lakotaubp When I boot up I get what you get (I get on start-up hold power button till buzz. Then One plus screen followed by UbuntubToch screen, then ubuntubtouch screen with five dots (goes through dots twice). At this point the screen goes black and I get another buzz from the phone and it goes through the whole process again. This time however (second time around) the black screen is shortly followed by the sim pin screen and then I am in.
    I must admit that since the last system update, I have been unable to reproduce the double shut down issue. Dare I say it the it is f…. No I will not say it and tempt fate.



  • @ukphil Still can't reproduce that. Lets see how things are after the next OTA which is due shortly.



  • @lakotaubp I have also had a double boot issue, but on my PRO 5. I never gave it too much thought, though. I do not often reboot my phone.



  • Force of habit with me, restart after app updates etc. Lets see if things have changed with OTA-5 though not sure exactly what effect that might have. So far we have two devices with the issue I think but info on UBports version and channel is missing.



  • @Lakotaubp sure lets see as I still have not got the double boot on shut down after the latest upgrade. However, still getting the double start up issue.



  • I've had this double boot issue for a long time on my E4.5 running stable. I also hoped that this would be fixed with the next OTA-update, but after every update nothing changed.
    I didn't want to wipe the phone because it's my daily driver so I searched for the problem. In my case it was a corrupt media database. I deleted

    "/userdata/user-data/phablet/.cache/mediascanner-2.0/mediastore.db"

    and then reboot the phone. After that everything was fine again.



  • @Flohack @Lakotaubp guys we have a few people mentioning this double boot issue on at least two devices now and we seem to have a potential fix by "kristatos".

    Would this be a good time to have this looked into, so others do not have to just put up with it?

    @Flohack is you need this testing, you know you only have to give me a shout on Telegram.



  • @ukphil Can you check if you have that .db first. If you do you could try removing it and see what happens. I'll be back in about 8 hours. Good luck.



  • @Lakotaubp I have just tried to access /userdate in Filemanager (unlocked) and it will not let me in. I will have to try at home in a few hours.



  • @ukphil Same with me.Lets see later. Thanks


Log in to reply