help needed with installation on nexus 5

  • Hi, I am a new here and I hope to get a little help and guidance with an installation on nexus 5 from experienced veterans since I get stuck in the process and I have no clue what´s (or where I am) going wrong...
    I followed the instructions here ( as best as I could; this is what I did incl. a few observations:

    1. bought a used Nexus 5 in good condition with android 6.0.1 and no SIM lock (I have no experience with android whatsoever)
    2. use available windows-laptop (admin-account), downloaded ubports-installer.0.1.21-beta.exe, installed “Universal ADB Driver”
    3. activated developer mode on phone, succeed to enable "USB debugging" mode but unable to select "OEM unlock" (since there is no such option available in the developer options list on this device)
    4. connect the phone via USB, the installer does not recognize it whereas windows recognizes it as "nexus 5"
    5. select device manually (UBports still asks to connect the phone via USB)
    6. press “install”-button, proceed
    7. successfully reboot the phone to bootloader mode (windows now recognizes the phone as "android"), the phone-screen says: "fastboot mode, ...., secure boot - enabled, lock state - unlocked"
    8. based on the video on the instructions website I expected an install-popup in UBports installer with "OK"-button ... but that was it - nothing happens...

    any suggestions?
    Many thanks in advance

  • @obacht Search for and try 15sec adb tools also installer 0.1.9 worked for me on Win 10. The 0.1.12 installer is also good.
    Before that restart the installer wait till asked then connect the phone but try another USB cable. Cables are a big part of issues. You could if it gets stuck at fastboot etc choose the clear cache option and try again that worked on nexus 7. Good luck and come back again if stuck. On mobile only so getting links is an issue sorry and have patience it can take 20 odd Mins to install on nexus 5 if I remember rightly.

  • @ Lakotaubp
    Thanks a lot for your quick and effective help!!!
    I tried "15 Seconds ADB Installer" and it made all the difference: Installation is complete (cable and installer (version .0.1.21) were OK as it seems).
    Now I am going to explore... 🙂

  • @obacht Great enjoy your Ubports Ubuntu Touch phone. Hope you installed 16.04. Quick tip charge the phone till the battery indicator goes white not just showing full. Helps a lot with battery life.

  • I installed 15.04 in the first place but updated to "Version 25" which seems to be the 16.04.
    The calendar seems to work with CalDAV but is there any way of synchronising contacts using the CardDAV standard? And how stable is dekko 2 comunity edition for mails?

  • @obacht I'll leave cardDav for someone else as not sure how to sort that or use the search function to check the forum for answers.. Dekko2 is working well for me even though its still beta.

  • @Lakotaubp Thanks anyway, I was about to give up and now I have a running system...

  • @obacht as Ivan mentioned here:

    "There is direct support for calendar sync in the calendar app, but you will need to manually set up a cron job in order to sync your contacts. This is a temporary issue: support for carddav should be added later in the contacts app."

    I didn't hear any news about that - so the problem is still there.

  • @neopar Thank you for that link.
    Yet I hope an UI approach for CardDAV will be available sometime, the CalDAv works fine already. I have no interest in putting up further server logistics and traffic while my email-provider (posteo) does all that already in a safe manner.
    I found: and
    ...but I have no experience in this sort of scripting or linux in general if you will (windows user).
    Nevertheless in order to try that out now I first have to figure out why the phone is on the one side recongised by windows (attached to usb and no errors in the device manager but still e.g. no diskspace available) but on the other side I cannot "talk" to it via adb ("adb devices" gives back an empty list whilst phone-debugging is enabled).
    I´ll have a break now and come back to it later...

Log in to reply