Libertine



  • Hi

    I've been trying to get MuseScore into the Libertine Container on my N5, but I'm struggling.

    There's a armhf.AppImage version, which I've downloaded and put into the "Downloads" folder of the N5.

    I've tried all 3 options in the Container (which is Xenial): Enter package name / Choose Debian package / Search, but It's not picking up anything.

    Any ideas?



  • Hi @3arn0wl ,

    you can't install the AppImage via the package manager, because it is not a Debian Package. AppImage is a separate packaging format, different to .debs or Snaps.

    For your case, you could install a graphical terminal application like gnome-terminal or mate-terminal in Libertine.
    In there you execute chmod +x Downloads/XYZ.AppImage to make it executable, then just run it with Downloads/XYZ.AppImage (replace XYZ appropriately).

    It's a bit redundant and uncomfortable, but it could work :)
    Feel free to share your progress!



  • Thanks for coming to the rescue, @haveaniceday. I'm displaying my ignorance, as usual!



  • @haveaniceday

    Hmm I tried both gnome-terminal & mate-terminal, but got "No packages are installed".

    I also found a Debian armhf MuseScore: <musescore_2.3.2+dfsg1-2_armhf.deb> but that didn't work either. :/



  • Oh, since there is a Debian package available, the process is far more simple than with the AppImage.
    I assume you have already created a container? If so, you can tap the + button in the container settings and choose "Enter package name or Debian file". A prompt ask you for the package name - where you type (exactly) musescore and push "Ok".

    Then you wait and the App while the app is being installed. After some time, it will appear in the X-Apps Scope.

    I just tried it on my M10. Although the user interface is very tiny, the program starts.

    Hope this helps :)



  • I deleted the container, and started again, and I'm pleased to report that musescore downloaded! :) Thanks for your support, @haveaniceday - it is really appreciated


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.