UBports Installer says "Success!" only it never is the case: Oneplus One



  • The title says it. I boot into Oneplus logo now. After "Success!" promt and "installing updates"(for about 3 minutes) I boot into Android bootloop. Can still boot into UBports recovery and stock fastboot though.
    At this point I think maybe some shady "root assistant" thingy shall be hold responsible, my device come from China and all that. The reason is after the very first "Success" my device boot straight into "ColorOS" and the root thingy is still there despite I chose wiping the device.
    Before you ask, yes, I have tried my luck on Linux(both debian and slackware based), Windows 10, switching UBports Installer versions, 15/16.04, devel/rc/stable, USB ports, cables, laptops. But it ONLY start downloading images on Windows 0.1.21 beta and that doesn't work out for me either.
    So, any thought? I am still pretty new to mobile OS in general and will be happy to find out this is a layer 8 issue, and hey, thanks in advance!



  • Ahhh, forgot the log https://share.riseup.net/901d0efd-c2df-4f34-9680-a8df5dbaf692
    Don't tell me it's due to port 5038?
    And the recovery log says "update faled"



  • @mxuser that link gives me a "404 page not found" error





  • @mxuser no problem :)

    Some random thoughts, and assuming you have adb & fastboot tools installed properly:

    • Is your phone encrypted? If the answer is yes, you should make a factory reset before trying to install UT
    • If you have tried the .deb installer package in Debian, you can try the appimage package
    • When the phone gets stuck in recovery, unplug it and plug it again (sometimes adb and fastboot fight for the same space)
    • If you want to keep trying with the windows version of the installer, make sure adb and fastboot are in your user $PATH or run the installer with admin powers


  • I'm actually debugging the installer a little at the moment. And found that for the linux version there is a fundamental difference between the snap version and the others (deb, AppImage) that is due to the handling of admin rights. Haven't understood all the little details yet, but from looking at the code and fiddling around a bit, I think the snap version should be tried if deb or AppImage don't work.

    Edit: if possible, the android tools should be installed via the distribution's package management; in that cases chances are best that the installer finds them in all situations



  • So I just TWRPly purged everything then tried again and it worked, windows 0.1.21
    You may not believe this yet this my first non-feature phone
    Time to embark on new journey eh?


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.