OTA-6 Call for Testing

  • There is this warning about certificate not trusted 0_1543500271424_screenshot20181129_140102622.png

  • Pardon my intrusion, @Teigneux maybe it's related to Increase swap space issue, which is discussed in other tread.

  • @advocatux said in OTA-6 Call for Testing:

    @teigneux if you only run one app, not several at the same time, does your phone crash?


    IMO 1Gb RAM devices can't handle more than 1 app open at a time, and even that with some care 🙂

    what? it worked well before. And not only with two apps. If i cannot listen music and read a sms at the same time, I will not longer use this system!

    Search for the word "Killing" in your log and you'll see how your phone is running out of memory constantly.

    I will check.

  • @jezek thanks, I will take a look. The phone is clearly slower than before, it should be a ram or a memory access issue.

  • Hm, I would like to join testing, but I cannot switch to rc channel.

    There is no channel switcher in the System Settings -> Updates -> Update Settings page. Is there other way to change the channel?

    It used to be there, I used flip to rc -> back to release to get OTA-5 update.

  • @kwah something is wrong in your phone then. You should be able to tap on "channels" in the "Update settings" page to select any channel you want.

    You can try to run this command in your device terminal sudo system-image-cli --switch 16.04/rc

  • Alarm clock is not trustable anymore, changed already in ubuntu 24. In ubuntu 26 w48 again it didn't ring and indicated just after turning on the screen. Phone was on charge, i checked the alarm time and turned actively off the screen in the evening. (clock app was opened when i turned the screen off)
    Something changed in the last updates, please check this.

  • @teigneux

    Yes, that log has exactly what I expected at line 125:

    Nov 28 17:02:32 ubuntu-phablet kernel: [10756.588033]Killing 'unity8' (2558), adj 10,
    Nov 28 17:02:32 ubuntu-phablet kernel: [10756.588038]   to free 113312kB on behalf of 'Thread (pooled)' (15633) because
    Nov 28 17:02:32 ubuntu-phablet kernel: [10756.588043]   cache 16288kB is below limit 16384kB for oom_score_adj 6
    Nov 28 17:02:32 ubuntu-phablet kernel: [10756.588048]   Free memory is -2764kB above reserved [gfp(0x200da)]

    This is definitely a memory problem which manifests heavily on devices with 1GB of RAM.

  • @htc_tattoo, we'll need more info than that to reproduce the problem. Which device are you using? How and when are the alarms set? Do they repeat? What is the position of each setting on the edit page?

  • @advocatux I am using a BQ E5 and a Nexus 5 - both with UT 16.04 RC.

    As you descibed above on the BQ E5 (with 1 GB RAM) I always have problems using 2 different surfing apps (e.g. QWANT and browser). One app is always freezing and starts again if I use the other one.

    This problem was also existing with 15.04. If I use e.g. SMS, phone, mail and QWANT, I do not have the problem - only with 2 'surfing apps'. On the Nexus 5 I don't have this problem at all.

    This is actually the most annoying problem on my BQ E5.

  • @mic_ yes, it seems that any app related to web browsing is more memory hungry than the other ones.

    I have the same problem with my BQ E 4.5 (also 1GB RAM)

  • Sometimes my BQ E5 crashs and returns to the "Ubuntu Touch" loading screen. This never happened until now on the Nexus 5. And it seems it happens less often with OTA-6. But at least 2 times until now.

    If my BQ E5 crashes because running out of memory isn't there a way to write data on the phone? You probably already tried....

    I now turned back to my BQ E5 as daily used phone - because the energy management of this phone is now really phenomenal !! (I always have enough power for more than 1 day). This makes it more handy than the Nexus 5. ;/

  • @mic_ yes, that's unity8 crashing after running out of memory, and no, swapping wouldn't be a solution for that.

    I have the same dilemma than you: battery life or stability. BQ E 4.5 against Nexus 5 :P, but I've chosen the latter as my daily driver

  • @advocatux I do not have "channels" in the "Update settings" page. Command you suggested resulted in error: Exception occurred during update; see log file for details

    Any idea, which log does it refer to?

  • @kwah have you tried to clean system-settings cache, data, and config files using UT Tweak tool? Then reboot your device, and see if you can switch channels.

    I don't know which log it refers exactly but maybe is ~/.cache/upstart/application-legacy-ubuntu-system-settings-.log

  • And I just realized that there is a difference between BQ E5 and Nexus 5 in getting notifications.

    While Nexus 5 immediately shows incoming new mails on the phone with a green light, BQ E5 is not doing that or a longer time later. It seems so that BQ E5 in standby mode is loosing or having less internet connections.

  • @advocatux nope, have not done anything with UT Tweak Tool. Or was it a suggestion to do clean / reboot 😉

    Don't see anything special in file you mentioned.

  • @kwah yes, it's a suggestion to do it 🙂

  • @mic_ I think there's some kind of issue with the notifications server currently. Maybe with the queue (?).

    Three days ago I stopped getting notifications in my Nexus5 but they were working fine on my BQ E 4.5. The next day, no notifications in the BQ either for a good while, and then suddenly in the afternoon I got like a dozen notifications all at once.

    The next day after that, both phones were getting their notifications without any trouble.

  • @unisuperbox Device: Nexus 5. I use the alarm clock for ~3 years, everyday at 7:10. Every evening i check the clock app to be sure it is not hanging (relict from ota2 ;-)), i connect to the current.
    At 7:10 it was silent. At 7:15 i turned on the screen, still silent. After checking the phone after making coffee i saw the indication lamp blinking.
    In the notifications it showed, that i missed the alarm.
    Last week similar problem, there it rang 10 minutes later again.
    I will continue testing, i guess the app crashed and didn't recover. Can i see somthing in log files?

Log in to reply