OTA-6 Call for Testing



  • @mic_ yes, it seems that any app related to web browsing is more memory hungry than the other ones.

    I have the same problem with my BQ E 4.5 (also 1GB RAM)



  • Sometimes my BQ E5 crashs and returns to the "Ubuntu Touch" loading screen. This never happened until now on the Nexus 5. And it seems it happens less often with OTA-6. But at least 2 times until now.

    If my BQ E5 crashes because running out of memory isn't there a way to write data on the phone? You probably already tried....

    I now turned back to my BQ E5 as daily used phone - because the energy management of this phone is now really phenomenal !! (I always have enough power for more than 1 day). This makes it more handy than the Nexus 5. ;/



  • @mic_ yes, that's unity8 crashing after running out of memory, and no, swapping wouldn't be a solution for that.

    I have the same dilemma than you: battery life or stability. BQ E 4.5 against Nexus 5 :P, but I've chosen the latter as my daily driver



  • @advocatux I do not have "channels" in the "Update settings" page. Command you suggested resulted in error: Exception occurred during update; see log file for details

    Any idea, which log does it refer to?



  • @kwah have you tried to clean system-settings cache, data, and config files using UT Tweak tool? Then reboot your device, and see if you can switch channels.

    I don't know which log it refers exactly but maybe is ~/.cache/upstart/application-legacy-ubuntu-system-settings-.log



  • And I just realized that there is a difference between BQ E5 and Nexus 5 in getting notifications.

    While Nexus 5 immediately shows incoming new mails on the phone with a green light, BQ E5 is not doing that or a longer time later. It seems so that BQ E5 in standby mode is loosing or having less internet connections.



  • @advocatux nope, have not done anything with UT Tweak Tool. Or was it a suggestion to do clean / reboot ;)

    Don't see anything special in file you mentioned.



  • @kwah yes, it's a suggestion to do it :)



  • @mic_ I think there's some kind of issue with the notifications server currently. Maybe with the queue (?).

    Three days ago I stopped getting notifications in my Nexus5 but they were working fine on my BQ E 4.5. The next day, no notifications in the BQ either for a good while, and then suddenly in the afternoon I got like a dozen notifications all at once.

    The next day after that, both phones were getting their notifications without any trouble.



  • @unisuperbox Device: Nexus 5. I use the alarm clock for ~3 years, everyday at 7:10. Every evening i check the clock app to be sure it is not hanging (relict from ota2 ;-)), i connect to the current.
    At 7:10 it was silent. At 7:15 i turned on the screen, still silent. After checking the phone after making coffee i saw the indication lamp blinking.
    In the notifications it showed, that i missed the alarm.
    Last week similar problem, there it rang 10 minutes later again.
    I will continue testing, i guess the app crashed and didn't recover. Can i see somthing in log files?



  • @mic_ said in OTA-6 Call for Testing:

    @advocatux I am using a BQ E5 and a Nexus 5 - both with UT 16.04 RC.

    As you descibed above on the BQ E5 (with 1 GB RAM) I always have problems using 2 different surfing apps (e.g. QWANT and browser). One app is always freezing and starts again if I use the other one.

    This problem was also existing with 15.04. If I use e.g. SMS, phone, mail and QWANT, I do not have the problem - only with 2 'surfing apps'. On the Nexus 5 I don't have this problem at all.

    This is actually the most annoying problem on my BQ E5.

    I realized a similar problem with the N5. Sometimes 2 screens of the browser cause apps to crash when you switch the open apps (morph and youtube, morph and openstore, openstore and system settings...). I described in "app suspend behavour", but until now nobody could see this error. I didn't find a pattern, these are random crashes.



  • @Mic_ FYI (or maybe you know it already if you're following our SuperGroup in Telegram), Dalton is doing some tests with swap memory and playing with zram :)



  • @advocatux Well. After a while, finally found it. It was not obvious... So, cleaned all items of system settings. It did not help.

    More ideas, anyone?



  • @kwah hmm... you can try to install UT again on your device using the installer but without checking the wipe option.

    You can also try a "factory reset". I don't remember the exact words in English, but it's in System Settings > Reset > Remove & Reboot (or something like that).

    If you decide to do this DON'T FORGET to backup of all your data.



  • @htc_tattoo I have this problem now also on the Nexus 5. If I open a lot of apps (more than 4), switching between them, the morph browser crashs and start empty again (open windows are away). The same happens on the BQ E5 always with even 2 apps.

    @advocatux Probably such a swap solution would help ;)


  • Community

    @Mic_

    While you are seeing the same behavior, the semantics are different. When Ubuntu Touch runs out of memory, it will kill an app and retain a screenshot of it in the app switcher. The app is not crashing, but it does need to handle this situation better. You may want to file a bug on morph-browser since it does not restore open windows when it is killed due to low memory.

    zram may help a little, but really the problem is that the system and apps are using too much memory, and you may be expecting a bit too much of your device. I've put in a PR to re-enable zram on the E5, but it will not be merged until after the OTA-6 release.



  • Alarm clock really does not work. Today i checked again, 11 minutes after the alarm there was just a notification that i missed it. No vibration, no sound (should do both on very low volume).
    Nexus 5, actial rc image. Please check it, it's a bug.


  • Community

    @htc_tattoo

    I believe you. I've been checking it. I've tried to reproduce the problem and I've asked people who have complained about it before to do the same.

    With that, I must say that "Please check it, it's a bug" makes me a little upset. It's mostly due to my own failure to reproduce the problem. I encourage you to file a bug rather than complain about issues on the forum. That gives us a better place to talk about it than a thread like this where lots of people are giving input. Also, you said the issue started occurring a couple of weeks ago? Did you mention it then?

    For relevant log files, let's start with the standard ones at Contribute to UBports - Bug Reporting. Please follow the instructions there to file a bug. Some more relevant information... Is the device plugged in when the alarm is missed? What is your "missed alarm time" set to in Clock settings? Does the notification you missed the alarm appear after that time? Does the alarm always fail to ring, or only sometimes? Do you use your device heavily before the alarm fails to ring? There's a lot of information that is potentially relevant that we just don't have here.

    I understand this issue is upsetting to you. I'm sorry I haven't been able to reproduce it. Please help me by following the normal process to file a bug report so we can get more opinions.



  • Don't be upset, I'm not complaining. I just wanted anybody to confirm if this a problem in N5 devices with OTA-6 or if it is just my phone.
    Thanks for putting the link for bug reports, i opened a new issue. In my opinion something from W46 to W47 changed in the software that causes this.



  • @htc_tattoo sorry cant reproduce either. Two alarms set worked as expected RC version 26 (W28).


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.