no wifi on hammerhead (OTA-6, 16.04/20181126)



  • Hi!

    I read about no wifi connection on hammerhead with OTA-4. And if I got it right, this issue should be gone.
    But I flashed my Nexus5 yesterday, OTA-6, and got no wifi.
    I just see lo, rmnet0-7, rev_rmnet0-8 and sit0. Should a module be loaded? Cause there is none.

    And is there a way to flash while being offline? My internet connection is quite slow and it takes hours to use the installer. I'd be really happy to download images at work and flash them later at home. I looked around the web page, but did not find it. Missed it?

    Greetings,
    Tharin

    PS: I appreciate all the UBport work so much! Thank you.



  • @tharin Before reflashing try updating to the dev channel in updates, update settings in System settings. That might fixit. You can then move back to whichever channel you like. Other than that its all the normal stuff, flight mode on and off restarting. Good luck



  • Thanks. But flightmode did not do the trick. Nor flashing newest radio firmware ( found that as solution for the problem in OTA4).
    Reflash would be faster than anything else which requires inet - guess what: inet via mobile is lot slower here than the cable bound, which is already slow. ;)

    A way to get things once and reuse them offline again would be a great help.

    Is there a way to use the usb connection to the pc to share the pcs connection?



  • @tharin Did you try changing to the dev channel in update settings that is a very small download and will give you the latest version of UT for your device it can fix a number of issues.



  • After almost 10mins of "Fetching channels" I thought, this is not the way to go. ;)



  • Tried it at work - no probl. Update was 456MB (well, not exactly small ;) ). Worked like a charm and I can see all WiFi networks here. I think, it'll work at home, too.
    Jippie! Thank you.
    And pleeeease: A possibility to fetch updates/install images at one place and install them (offline) at another. :)



  • In case somebody might have similar issue and settings:
    I found rndis as solution for any useable inet access at least.
    Docu here: http://docs.ubports.com/en/latest/userguide/advanceduse/reverse-tethering.html
    I had to set link up and give address manually. But jippie, it works. :)
    (WiFi stopped working. Was not able to get it working again.)
    I got inet connection on the phone, but it seems to not use this connection for "fetching channels" - wheel's turning, no traffic seen via tcpdump on the rndis interface of the pc.

    Still: Some image/packages to download would still be great. ;)


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.