WhatsApp Web

  • Hi all!

    I have been using WhatsApp Web on my UBports phone successfully for quite a while now. Since yesterday I cannot seem to access https://web.whatsapp.com/ anymore with the webbrowser app and am automatically redirected to https://www.whatsapp.com/. I assume that it is somehow automatically detecting that I am using a mobile device.

    I would be very greatful if someone could point me to a workaround to be able to access https://web.whatsapp.com/ on the webbrowser app again...

    Many thanks!

  • Oh yes, ticking "Set Desktop mode" in Morph Browser did not do the trick. I am still being redirected to the mobile website. Isn't there some other way of forcing the desktop version?

  • Out of interest, are others able to go to https://web.whatsapp.com/ with Morph without being redirected to https://www.whatsapp.com/ ?

    Or is someone able to access the QR code?

  • @maxx The whatsapp webapp stopped working for me too. Both in the webapp or accessing directly through morph, it asks me to install a newer version of Chrome. I guess the version that morph is showing is being seen as old by https://web.whatsapp.com/.

  • Hmmm that is a shame... running WhatsApp via browser was a nice workaround to use this (annoyingly ubiquitous) messenger on UBports. There must be a way to get this to work again, though?

  • Even with latest Chromium (71), it's telling me I need a newer version of Chrome (36+). I think WhatsApp just doesn't support the free browser any more, and it seems unlikely this will work again in Morph.

  • Indeed this seems to be a generalized problem, not specific of UT and its current web browser (Morph). In this thread they suggest to change the user agent to chrome. I think we have to create a new webapp and play with the user agent:


  • I did some experiments. I created a new whatsapp webapp using the User Agent suggested by the thread I linked. With this webapp, the first time it is opened, it connects correctly the QR. After scanning it, it connects to my whatsapp server. But if I close and open again the webapp, the "update Chrome" screen comes up again.

  • I managed to create an app with QTWebengine for Whatsapp Desktop which allows me to read my Whatsapp groups from time to time, the only thing I need since I'm not using Whatsapp myself. I just published it to the Openstore.

  • @wgarcia But doesn't that require that you are logged on an android phone somewhere and with tbat you scan a barcode on your desktop watsapp?

  • @mihael Yes, this is just the desktop access. The problem is that when we moved to morph it started complaining that chrome has to be updated. It actually works the first time, and if it is closed and opened again it asks for Chrome 36+. If the cache is cleaned it opens again OK, but it has to be cleaned each time so it cannot be sync with the actual Android running Whatsapp. I tried to use QTWebengine to change the user agent to fake it, which can be also done directly in the webapp creator, but also to increase the persistence of the storage to try to avoid the problem after the restart.

    It has worked for a couple of days but right now it started failing in restart again, so back to square 0.

Log in to reply