Nexus 5 flash fails; Universal ADB Driver installed - 32-bit Win 7 Pro SP1



  • @rvan You only need bother with the Information section, number 1 Unlocking the boot loader. You've done the rest. Same as my post above really.
    Then you can try installer again.



  • If I can jump in here. I too am having problems with the installer on an N5. After much buggering about, I managed to get it to do the fastboot part, but when it reboots into UBports revovery, the installer fails to detect it. I have run "adb devices" at this point and it is quickly detected and that it is in recovery mode. I wonder if the installer is putting the "./" in the adb commands?
    I have used three different PCs and installed Ubuntu on one, also several different cables, all to no avail. I fear the installer is the problem.



  • @judderman2 what ubports-installer version are you running, and for what OS?

    Anyway, try to unplug and plug again the phone when you're stuck in that recovery step. Sometimes adb and fastboot fight too much for the same space 🙂



  • Thanks for your reply. Mostly Win10 64, but also Win7 64 and Ubuntu something or other. Yes, have tried unplugging and replugging, still no joy, shame as I'm really looking forward to trying it, so fed up with Googley andwoid. Loved WebOS, it got killed, BlackBerry 10 was decent, it got killed, SailfishOS shows promise, but need to have android apps support, so not ideal; please, someone, spare us all from android



  • Installer version 0.1.21-beta



  • @judderman2 one pretty common issue with windows is that the necessary tools are not in the user's $PATH. Check that or run the installer with admin powers



  • Always run installer as admin. Fastboot and ADB installed globally, but have also tried putting the path in.



  • @judderman2 you can try an older installer version then. This version for example https://github.com/ubports/ubports-installer/releases/download/0.1.12-beta/ubports-installer.0.1.12-beta.exe has a great success rate on windows



  • ok, thanks, i'll give it a go and get back to you



  • @judderman2 good luck!



  • Nope, same thing, goes through fastboot stage quite quickly (after manual selection, never auto detects), reboots into UBports recovery, but installer doesn't see it. Are files available to flash with fastboot, or is it o different to android that that won't work?



  • @judderman2 is there anything relevant in the installer log?



  • where would they be? Do you mean the recovery logs UBports recovery?



  • @judderman2 nope. I don't really know about windows but it should be somewhere in %APPDATA% (I think).

    You can try https://github.com/ubports/ubports-installer/releases/download/0.1.9-beta/ubports-installer.0.1.9-beta.exe as well. That's another version with a high success rate



  • Nah, same result. Many thanks for your time, but I've taken too much up of it, especially so near to Christmas. Maybe someone in the UK would be prepared to flash it for me, for a "consideration"?



  • @judderman2 yeah, that would be great 🙂

    Anyway, another good way for windows users is to use a Ubuntu usb stick (https://tutorials.ubuntu.com/tutorial/tutorial-create-a-usb-stick-on-ubuntu#0) and install there the necessary tools. You also need to enable the universe repository in your sources.list to install them).



  • I have a duel boot machine which I have tried, but know about universe repository, will try that when I get home after Christmas and report back.
    Thanks again
    Seasons Greetings



  • @judderman2 you're welcome!

    Have a great holidays!!



  • Unfortunately, my results have not improved either. My bootloader remains locked. I appreciate others jumping in here as it helps the cause. I have tried three methods:

    1 - Download zipfile for full Android SDK and extract only. As stated here (https://forum.xda-developers.com/google-nexus-5/general/guide-nexus-5-how-to-unlock-bootloader-t2507905) and above in my response. This presents itself as a less involved means of accomplishing the goals required for the ubports installer. Nonetheless, I was unable to locate the sdkmanager.exe referenced in this xda thread and this should have been stupid simple. This thread was written in 2013. I must allow for doing something wrong but, these are simple tasks to perform.

    2 - Download full Studio and install - Could not find relevant information on how to proceed with this method, so I migrated to #1 above. Note, I uninstalled Studio before proceeding so as not to confuse zipfile extraction, sdkmanager.exe, etc. I have no interest in developing apps but, the Studio may well be the best way to go. If I can determine how to accomplish this I will but, this should not be necessary to unlock the bootloader.

    3 - Shimp208's Minimal ADB & Fastboot - This is the 15 s tool mentioned above. I have focused on using v 1.4.3 because, this is suggested for the version of Android on my N5 (6.0.1). My hardware configuration should meet the prerequisites listed under "How to Install." Notice he references guides for ADB and Fastboot. The ADB guide references the Java Runtime Environment (jre) or Java SDK. The only significant comment I can make here is that I use ImageJ/Fiji. These digital image processing applications require Java and they are working on this same laptop (i.e., lenovo X201, 8 GB RAM, 64-bit Win7 Pro SP1) so, I suspect I am okay in meeting this requirement but, have not determined a means to prove this. Maybe and environment variable issue? I will look into this.

    Driver - I have been using the Universal Adb Driver for most of this. This permits me to see the Nexus 5 in the Windows System Tray when connected to the X201 and USB Debugging is enabled. I also see a Google USB Driver under "Android Device" located at the top of the listings in "Device Manager." These indicators give me confidence this driver is okay to use. However, I finally located a driver on the LG website but, it appears to be a universal one. This is LGMobileDriver_WHQL_Ver_4.2.0 and my results with these tasks have not improved.

    I have also located methods to unlock the bootloader of Android phones using key press combinations or sequences. I do not know if these work for the N5 and have not attempted to use these.

    I am not sure what to think at this time. Giving it a rest for Christmas. More later... All this suggests this is something simple that is being overlooked so, a clear mind is best.

    Thanks for the assistance! Merry Christmas!



  • Good news, I have now finally managed to install under Ubuntu. Couldn't find ADB or Fastboot in the app store, but when I tried to call them from within a terminal (to see if Ubuntu was detecting the phone), it very helpfully gave me the commands to install them. Once they were both installed, I ran the Ubports installer again, it still didn't auto detect, but under manual select, it ran to completion, I now have Ubuntu Touch on my Nexus 5 🙂
    Many thanks for your help


Log in to reply