[SOLVED] VPN: 'no vpn secrets' error

  • Adding this because it was frustrating for me and I could not remember this solution when setting up a new device.

    Firing up a valid VPN connection from these instructions (mostly) gave me the message:
    "VPN connection XXXX failed because there are no vpn secrets."

    This setup uses a USERNAME / PASSWORD for authentication.
    Changing username/pass to remove ALL non-alphanumeric characters from the BOTH the username and password fixed this.
    This requires making changes with your provider credentials
    ex: my_username => my123username

    I'm pretty sure this is an encoding issue, but I'm not sure where to bug-post it.

  • Hi, I've hit this exact issue with PIA. The logs reports "locked collection" and (apparently) can't save the password. However, for PIA... everything is alphanumeric, so your solution has no impact on the problem I'm experiencing... which is the same problem you have... did you do something else too?

    I even set a password in the system-connection conf files but it didn't make the slightest difference. However, I might have things set incorrectly, I need to look at it again.

  • I followed the instructions on the blog post above almost exactly.
    The only difference was that I had to extract the CRT and the TLS key from an .ovpn file to separate files for import.

  • @circ Hi. If i well understand what's you say,
    VPN works for you on Ubuntu touch. I followed the tuto step by step (VPN editor) and it doesn't work for me with PROTON VPN free on bq E5 and OPO both rc Xenial, neither on BQ M10 HD dev Xenial (lost of password on it).
    So with what phone(s), what VPN provider (free or paid ?) does it work for you ?
    Did you exactly follow the settings of the tuto or change some parameters ?

  • @domubpkm
    I'm on a Nexus 5, Development channel.
    I'm not using a free Proton account, so I had to pull the CA certificate (.crt in blog post above) an the TLS auth key (.key in blog post above). I did this by opening an .ovpn file that otherwise works and extracting those parts of it to separate files. This gave me what is referred to in the post as the needed files.
    Otherwise, I followed the setup instructions as they are written - I found the screenshots most helpful.
    I should also note that I'm not connecting to a free ProtonVPN server, though I doubt that woulds make a difference. Do you have another way to check the configuration you are trying (like a laptop or other machine running OpenVPN) ?
    One thing I did do first was to make sure I could use the config I had successfully outside of UT.

  • @circ Ok thanks for your answer. I will continue testing in the coming days.

  • @circ Hi. I continue my investigations. So PROTON VPN works for me with windows 10, Ubuntu 16.04 (using a command line
    sudo openvpn <config.ovpn>), but NOT yet on ubuntu touch whatever the method used.

    So, two more questions : are you on 16.04 and are you using the provider proton vpn (the answers of the two questions could have significance, i read things).
    Good new year.

  • @circ Thank you for your help, now it works on my BQ E5 HD, so surely on other phones.

    The Tuto vpn 2, is clear, simple, nothing to say about it.

    I don't know if it's completely about that because i tried many times and it didn't want to work.

    But for Everybody :

    Only one false character will cause connexion problem !

  • @circ @domubpkm Hey so I'm having the same error code with my Ubuntu Phone VPN connexion.
    I changed username and password to avoid non alphanumeric characters.
    Do the name and location of .ctr and .key files have any sort of importance?

    ca.crt has the form:
    -----END CERTIFICATE-----

    and ta.key has the form
    -----BEGIN OpenVPN Static key V1-----
    -----END OpenVPN Static key V1-----

    Both are extracted from the xxx.protonvpn.com.udp.ovpn file downloaded on my protonVPN account.

    Could the gateway port number be an issue?

    Do you have any idea why it still doesn't work?
    Thanks a lot for any kind of help or suggestion!

    Edit1: Note that the password is always missing when I open the VPN editor app, but that could also just be some kind of security. Is that the expected behavior?

Log in to reply