No sim recognized in Ubuntu mx4



  • Hello tried everything from cleaning pins to reset phone to try different sims even from different countries. Used the phone internationally and suddenly no sim recognized. My idea please?



  • @giukas I've recently replaced battery on mine so I had to unscrew the back cover and prior taking that off remove the sim card from the slot. I am not sure what I did wrong but I had to re-insert the card to that slot a few more times in the next few days until I am finally not experiencing more such issues.

    Fortunately in my case removing the sim card, cleaning the slot as well as the card and reinserting it fixed the issue (after a few retries).

    This doesn't seem like system related issue though (especially since it does work for me). You can try installing Android on your device and see if it works there, but I suspect it to be a hardware issue. If that's the case that you may want to try cleaning the slot again and if nothing helps either ask some cellphone service to repair it or purchase a new device.



  • @zubozrout thanks for replying. I did replace the battery too but everything was working. I did flash Android but same. Any advice on how to clean sim port as very tight there?



  • @giukas I don't know :(. All I did was that I used some clean alcohol to wipe the SIM card and regarding the slot I've just looked inside if there is something visible that would cause the issue and haven't seen anything. So I just blowed some air there ... and it still wasn't ok since the contact was lost later again so what resolved the issue for me was to push the card into the slot thoroughly ... maybe I haven't had it fully inserted before ... there could have been some dust there that have prevented me to place the card correctly.

    Not sure ... but be careful and try not to destroy the slot it if isn't yet :). Good luck.

    PS. It could also be a SIM card issue. You may want to try another one to see if it works or try this one in a different phone.


Log in to reply