Connection cable between motherboard and screen (M10 FHD)



  • I have a BQ M10 FHD and I stumbled on a problem with my connection cable that connects LCD screen and motherboard. The cable only works in one special position and that means that a tablet has to be still when using it. Even that position changes every time I reboot.
    I am on the RC channel and I try to help the team with finding bugs and reporting them.

    Does anybody maybe has a broken tablet and thus have a spare parts?

    Thanks



  • @lapor hi, as that site has a broken certificate, and as it's easier to see that picture here in this Forum than the need to go to a third party site, I've removed your link but here's that picture:
    cable.jpg

    (Thank you for your understanding 🙂 )



  • @lapor about your issue, why do you think that cable needs a "special position"? Is it loose? Is it broken? Can you "fasten" it, so to speak?

    Another idea: if the issue is just a problematic cable, maybe you can contact BQ and see if they can ship it to you (https://www.bq.com/en/support/help).



  • @advocatux thanks for fixing the picture. We have self signed certificate and sometimes it produces some issues.
    About the cable - it is broken, and the screen gets weird artefacts, until you get the right pressure on the cable itself. I use two fingers to find the position and then I hold it like that. And then I use tablet very carefully with the other hand.

    I spoke to BQ, but they don't sell/ship parts. The only way is to send it to Spain and they fix it. But I don't want to pay for the post and the repair. I would like to fix it myself, as it is not under the warranty anymore. Maybe I can buy this kind of cable somewhere?



  • @lapor if I'm understanding you correctly, the cable (flex) that's giving you a headache is that labeled "9146C V2.0". Is that correct?

    Have you checked if it's making a good connection. Maybe you can try to reseat it (be careful).

    BTW after a quick search in some well-known sites, I see that you can buy that flex online. I've sent you a link by PM to give you an idea of the price, and what to expect 🙂



  • Actually it is the other one, the shorter and wider, with label "9145C V3_0".
    I'll try to reseal it and if that will not work, I'll check on the ebay or amazon.

    And thanks for the link in PM



  • I tried to reseat it, but now it doesn't show anything, it just turns black screen. I order the cable on ebay (the correct one) and I'll try again when I get it. I will report it here and I hope to use the tablet soon 🙂

    @advocatux thanks for your help



  • @lapor you're welcome, and I hope the flex you ordered fixes that issue without any more troubles 🙂



  • I managed to order one from ebay, but unfortunately it's not the one. It's 9147C instead of 9146C. It was written for BQ M10 FHD. I guess there is a new one as well. I tried it nevertheless, but it's not the right one. It a bit to wide on one side.

    So for now, I'm without a media to test/use ubuntu touch 😞

    If someone will find a spare connection cable, let me know. Until then I'll be a passive observer.

    Cheers


Log in to reply